Download

Direct Light appears in a closed room

Hello
I have a little problem:

I created a stage with direct light and inside this stage I made a room without any kind of inner light. The strange thing is that the room reflects the direct light, illuminating the room and seeping through the unions (there is no opening) I leave here a screenshot, I hope you can figure out what is the problem. They are Static Mesh, they are not BSP and they have UVs.
Regards.

24f311720ed09f59c7b534e947eb27482a7bacab.jpeg

Did you build your lighting?

Yes. The room is totally closed and without any light source.

Are those walls closed meshes like boxes or planes with a single face?

It’s a rectangular box with 6 faces. I put 6 of these box to create a closed room for a fast test.

The back faces don’t block light by default, that’s an option you have to enable in the static mesh, or make sure that you have another mesh for the other side of the wall.

The Static Mesh has faces everywhere, here you have a screenshot of the piece with its UV Light Map.

a8edd26be4104f69eb53b9f51c46e81e20350842.jpeg

A screenshoot for the outside, this is the room:

error3.jpg

Try making another box to encase your room

Also if you’re building at preview quality you can tend to get light bleeding through edges even though they’re all sealed.

With production light and another SM, fail too…

That’s really strange. Have a look in the static mesh settings, has cast shadow been turned off by any chance?

Hmm, can it be a smoothing group problem? Looking at your second last screenshot it seems possible. Try setting a smoothing group for each face of the floor mesh and then reimport(or let the editor to calculate normals and tangents and then reimport.)

Nothing…

I setup another ROOM with UnrealEngine/StartContent/Shape_Cube, the Normals are fine, but the light enter in a closed room.

The scene using a Distance Field Shadows.

Hi Aidan,

I’ve setup a similar test case using the third person template (just because that’s what I had loaded up at the time) with a wall I had made in 3Ds Max. I setup a closed box, similar to your setup.

I tested this with two instances.

For my setup I did apply the m_Metal_Chrome material since I know it’ll produce a reflective surface.

I used a static directional light with light built on Production and got no light bleed, but did when building on preview (this is expected).

Then I switched to Distance Field Shadows by setting my cascaded shadow map distance from 20k to 0. I enabled DFS and left at the default settings. Rebuilt lighting and I still have no shadow bleed.

Can you test this setup as well and if you’re still having the same issue can you post a screenshot of your directional light details panel?

Thank you!

Tim