digital Mike crunchy hair in 4.21

Hi all,

Wondering if I miss a setting the in engine or project setting that keeps the hairs look super crunchy or chattering.

The digi mike looks totally fine in the library sample scene but when I migrate the asset to another project, the hairs, eyebrows, eyelashes lose the smoothness and looks pretty harsh.
I have cross-checked project settings to make sure settings are consistent between my project and digital human sample project.
Engine scalability is all Cinematic. Material quality is high.

Everything else looks fine except that the hairs, eyebrows, eyelashes are very crunchy and chattering.

I didn’t change the hair material at all. Did I miss something on the engine or project level that may affect how the hairs look in the viewport?


Do you have “temporal AA” on? It’s pretty much required for the hair to look good.

Are you referring to project settings > Rendering > Default Settings > Anti_aliasing Method?
I have that set to Temporal AA.

Did you try setting anti aliasing in your “engine scalability settings” to something like epic or cinematic? (I think at medium and lower temporal AA gets turned off and you’ll get fxaa instead)

You could also super sample by adding a “execute console command” node with “r.screenpercentage 200” to the level blueprint. Very costly though.

Make sure ‘realtime’ is enabled, otherwise TAA won’t work properly after moving the camera. Also make sure TAA is enabled altogether in the viewport. If you press ‘G’ and see something change(other than the icons disappearing), then your Viewport settings are wrong. You can click on “Reset Viewport” to make sure everything else is enabled.

I am overdriving the screen percentage to 200 at the moment as a workaround. What I don’t get is the same asset “final_mike” hair looks smooth or doesn’t have this crunchy/chattering look in the demo sample level, so I am curious if there is a setting that I miss to get the hair smoothness back.

Thanks guys. I noticed the bloom in post-processing was turned off in my project. With that turned on, it alleviates some of the chattering issues. It could be the convolution blur kernel in the Bloom smoothes out that a bit?