Download

Different Lighting on Planes

On my walls throughout my level, the lighting is changing on the surface even in the same plane. I tried raising the light map resolution, but that didn’t seem to help. I know it’s splitting it where the UV unwrapping occurs. The walls here are one mesh. Is there any way to fix this so the whole plane is lit the same?

Screen Capture.png

If it’s one mesh, unwrap it so that the entire surface is one UV island.

If it’s one mesh then you also don’t need all of those loops

If it’s not one mesh, then this is why the issue happens: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

I think that is my problem. It is one mesh, but it is still split up into many polygons/faces. Those green lines are showing the result from the unwrap, but the model coming from Revit into 3DS splits the faces of the walls like that. I can’t seem to figure out how to merge those faces together so it reads as a single polygon, which I would assume would get rid of the different shading in Unreal.

To get it put back together, select all of the vertices and use the Weld option, select the button next to the Weld button so you can set the distance threshold for welding, I usually use 0.001 for that if the vertices are in the same exact place.

I’m not sure if the vertices are my problem. Because I tried welding, but that doesn’t merge the faces back together. Maybe this screenshot shows it. The face of the wall is split into individual polygons, even though they are coplanar. I need to get those polygons merged as one I think to allow the unwrap to read it as one face.

If those polygons are already attached, then you can select a line segment or a loop and click Remove, hold CTRL while clicking Remove and it will also remove the vertices that the edge was attached to rather than leaving a vertex on a line.

You may want to send an image of your UV. But it’s good to have your coplanar faces, vertex attached or not, be aligned in your UV. This ensures that regardless of the light resolution, they’re going to receive light in the same way. Just better.

I’ve included an image that shows a quick example (only focusing on the UVs for the particular side). It’s less about the Vertex welding, and more about using the Quick UV tool inside of Unwrap UVW.

d39b73310c84d44ec2b2edda4007d31b88922cbd.jpeg

the numbers are:

  1. Select all coplanar faces (regardless of attached or not)
  2. Check the way it should face. By default (shown) it will average out the normals, on a flat face, it’s fine, but I still prefer to specify X, Y, or Z.
  3. Click the Quick UV layout.
  4. This is the result, flattening out the selection relative to the direction made in 2

I use this feature ALL OF THE TIME. Helps to create an even light distribution. I also use this when doing tiles. and other things that have small creases.

It’s still good to ensure proper welding, and won’t fix every potential issue. But in the case you don’t have things welded, this is still a VERY good way to help improve the way the light functions over an object while giving a LOT more flexibility to create an even look, regardless of Lightmap resolution.

Hope this helps!

I’m guessing this is more of a 3ds issue than an Unreal one. I’ve tried welding the vertices, but when I try to remove the edges on the image to the right, it is just deleting the whole face. You can see if I drag it over, the edges are still separate. I can’t seem to combine those faces.

My UV unwrap is way to complex to do that I think. I’m trying to figure out how to simplify it, but the walls coming from Revit are very complex as you can see on my unwrap using Steamroll to the left.

For some reason I can’t upload the image right now…

Another important note is that it’s not just a matter of the Lightmap resolution, but how the lightmap is calculated through lightmass. It has some similar functions to other raytracing tools found in 3ds, how photons are bounced, calculated, approximated, etc. There’s a bunch of write-ups on this. I tend to like this one HERE. But even then, your UV map for the lightmap is problematic, leading to…

Steamroller’s got it’s pros and cons, but I don’t typically use it for any key meshes, including walls and buildings. I’ve worked a lot with models coming from Revit -> 3ds Max -> Unreal. Revit is a pain, and it’s almost not worth trying to fight the welding too much. However, the technique for UVUnwrapping should still be the fastest way to create an even lightmap distribution. I use it for all sorts of things that are geometrically complex, but need to have the lightmap calculate the same across it. But if you have your coplanar faces (the ones in my image selected in red, they are all next to eachother) scattered and rotated all over the UV map, you’ll likely always see this.

I run into this issue quite often for the same reasons. Maybe try when you unwrap, uncheck the rotate clusters option, and select unwrap by material ID, and see if that works. Also, as a way to QC the output, in the top right corner the pull down menu where it says checker pattern, if you pull down that menu and just re-select the checker pattern, it will project the unwrap onto your geometry in the main viewport of 3DS, so it should help your back and forth process… Unfortunately, this task out or revit is definitely not a linear process. I have had some success using the revit addin created by Twinmotion (attached image). Give that one a shot and see how it works out, in some cases you can skip 3DS max all together using that tool…
ad3fcd50488f9df76995ecb209123f0ff4b3e679.jpeg