Download

DFAO Noise in foliage

ezgif.com-gif-maker (4)

Hi guys, I’m creating a project using the Arch Viz template in 4.26 - I’ve disabled raytracing for now to troubleshoot issues, and enabled DFAO to try and get more contrast in my grass.

The only issue is I don’t understand how I can clean up this noise in shadowed areas? I’ve cycled through loads of settings, the only thing that removes it is disabling my movable skylight shadow (I’m using the default sun/sky component)

Am I doing this wrong? I would have thought the default lighting setup for the Arch Viz template would have appropriate light setup for grass, but without DFAO it looks super flat (unless I turn on high sampled Ray Traced AO, but thats not really feasible atm).

It looks like RT AO or RT Shadow in the skylight.
Do you have a post process volume active? If so, check if AO is on and the settings on it.

RT is turned off completely with this screenshot!

Its a bit hard to see in the gif, but is the noise happening on every shadow or just where the grass is?

does the grass have any vertex animation on the material’s world position offset? it kinda looks like it but it’s hard to see on that gif.
if so, know that DFAO is tricky to use with vertex animation because while the rendered polygons are animated the DFAO is static, creating a discontinuity of the place where DFAO should be applied.

try disabling the wind on the grass material and if this ‘fixes’ it you’ll know that’s the issue. if so, look for some older discussions about DFAO and wind animation on foliage. I recall there being some material trickery (involving pull-vertices-to-camera and pixel depth offset) to improve it.

It’s only on the grass, and yes it’s Megascans grass so it has wind - but even if you disable the wind it’s still noisy/fuzzy - it just doesn’t move. Do you just have to disable skylight shadow or use stationary then with DFAO? How is foliage usually handled with DFAO?

Yeah I did some testing here, the noise is part of the moveable skylight, I dont know if it can be removed.

Sorry for all the edits.

Are you using landscape grass? If so my suggestion would be to use the foliage tool instead, and turn “affects distance field lighting” off in the foliage settings for your grass. You’ll have to paint it where you want it, but it should soften the noise a lot.

1 Like