Destructible Mesh Interior Material Issue

My interior material not affected fractures on my Destructible Mesh. How can i solve this?

Im using last version (4.19).

Edit: Same unanswered problem is [here][1].

Edit2: Another unsolved problem is [here][2].

If anyone need a solution, maybe can help this:
I turned on v4.17 and it was works perfectly. Then i have set what i need on DM and migrated to v4.19. This is solution for me for now.

But there is still a bug on v4.19.

Had this same problem with 4.20, tried the 4.17 workaround and that works, but unfortunately this is still broken in 4.20 as well.

It was broken by some changes since 4.18 . My quick fix for this is adding this line to DestructibleFractureSettings.cpp ( if you use C++ version of the Engine, the file should be inside UnrealEngine\Engine\Plugins\Runtime\ApexDestruction\Source\ApexDestruction\Private :

		FCStringAnsi::Strncpy(SubmeshData.mMaterialName, "InteriorMaterial", nvidia::apex::ExplicitSubmeshData::MaterialNameBufferSize);

to this block of code :

	// For now just copy the submesh data from the 0 submesh.
		apex::ExplicitSubmeshData SubmeshData;
		apex::ExplicitSubmeshData* SourceSubmeshData = HMesh.submeshData(0);
		if (SourceSubmeshData != NULL)
			SubmeshData = *SourceSubmeshData;

		FCStringAnsi::Strncpy(SubmeshData.mMaterialName, "InteriorMaterial", nvidia::apex::ExplicitSubmeshData::MaterialNameBufferSize);

		// BRG - this is being done until I add the ability to reset the submesh data without resetting the mesh data in the fracture tools
		if (HMesh.submeshCount() > (uint32)OriginalSubmeshCount)

Hey PhungDinhThang ,
I tried to add the lines you wrote to my code but still it does not work, Do you have more knowledge on why it is not working? I am in 4,23 The compile worked but did not change the issue in the DM editor.

They have since fixed the problem. I am in 4.25 and it works without that line so may be you can try update to latest ( 4.25 ? ) otherwise I think it’s could be something to do with the way your static mesh is setup.
Last resort would be just put a breakpoint around there and step through the code it and see why UE4 did add a new material for the generated DM.

Ok ill give it a go, really they fixed it in 4.25? I thought it would just get worst with the engine update since they said they wouldn’t fix anything for apex destruction anymore. I am afraid that other plugins will break my game if I jump to 4-25 . Major changes like these forgotten plugins can result in tremendous hours of work to re adapt new methods just to match new products throughout the whole game and we are pretty far in the game progress for now :confused: .
I think it really fails around the fracture button : cause cause like HyprogenX said, if I go and make my DM mesh in the engine version 4,17 and migrate it to 4-23 then all works well but if I dare try to modify it afterwards in 4.23 and re fracture it then its back to broken material slots when I press the fracture button.

Thx for the answer I’ll try to keep on digging.

Sorry, on a closer look, they didn’t fix it in 4.25. I recently have to create a new DM and had to readd that line again to make work. Anyway , I think they are moving away from all this Apex stuff anyway and use the new Chaos destructible, so this won’t be fixed properly I think.