Download

Desperatley need help figuring out whats wrong with this spotlight

Ok, Somethings going horribly wrong with this spotlight I have on. I’ve posted about this before with no useful results. I have a spotlight on my character to simulate a flashlight. But there are three things wrong with it that I just CANNOT figure out.

A) I cannot get it to cast any shadows. I’ve tried time and time again but I just cannot get it to work.
B) Checking the “cast shadows” button drops like 30 frames. Why is that? Is there a way to fix it?
C) More recently, I’ve been getting these weird freaking lines everywhere.

I can’t figure it out. PLEASE help me somebody. I’ve isolated the source of the problem, it’s almost definitely coming from this spotlight I have in my character blueprint. I don’t have these problems with other spotlights and light sources. I am so hopelessly stuck with this.

The murare lines is the shadows bias, i think.
Check the posprocest in camera player.

Don’t set shadow bias to 0.0 (in your last pic). Set it to default and you’ll get rid of the black lines.

The lines are due to the shadow bias set to 0. You can sometimes remedy this by increasing the Shadow Filter Sharpen (just below), but that will make the shadows become sharper as well. Experiment with different values for these two and you’ll probably get a good result eventually.

ok yeah changing the shadow bias definitely got rid of those lines, but the light still isn’t casting any shadows. How do I change this?

Now I might be misreading your screenshots, but it looks like the light IS casting a shadow. However, since the light source is at the same position as the camera, the shadow is perpetually hidden behind the shadow-casting object. If you eject from the player character and look at the scene from a different direction you should be able to see what I mean.

That’s what I thought at first too, but I’ve ejected and shadows are definitely not being cast.

UPDATE: I deleted the spotlight altogether and created a new one. I’m getting shadows now, but I still have no idea what was not giving me shadows before.

You had “cast shadows from cinematic objects only” enabled before. Maybe that was why.