DepthFade node in translucent material crashes Particle Editor preview

Branch: Source build

Build version: 4.9.0-0
[link text][1]

Steps to reproduce:

  1. Create a new Material
  2. Set blend mode to Translucent, lighting mode to Volumetric Directional
  3. Create a DepthFade node, connect to Opacity
  4. Create a new Particle System
  5. Set the Material created in Steps 1-3
  6. The Particle editor crashes, triggers an assertion in SceneRenderTargets.cpp, line 2218

[1]: DxDiag output

Hello SpookyFM,

I tested this issue on my end in the 4.9 Source build, and did not get the crash you are experiencing after following your steps.

Would you mind taking a look at our How to Report a Bug post on the Forums? This will provide you with instructions on how to locate this crash log and attach it correctly to your response in a zipped folder.

Let me know if you have any other questions and I will be glad to assist you.

Thank you,

Thank you for your answer. I have zipped the crash report folder and two .uassets which cause this crash. To reproduce, I open the included particle system which uses the included material, and the editor crashes.



Crash report

Hey SpookyFM,

Unfortunately I cannot reproduce this issue with the files you have provided. Whenever we request a user provide their project, we ask they take the Content, Config, and Uproject files/folders only and zip them into a folder.

This will prevent any compatibility issues or assets failing to load.

Once we can get this issue to reproduce with the project you have provided, I can add this to the official bug report.

Thank you,

Thank you again for your answer. I was following the instructions here: How to report a bug - Feedback for Unreal Engine team - Unreal Engine Forums, so I only uploaded the uasset in question.

I have now zipped the Content, Config and .uproject and uploaded it. Thank you for your assistance (88.7 KB)

Hey SpookyFM,

So even with your full project with the issue occurring on your end, I am unable to reproduce this issue. I tested this on a Windows 8.1 and Windows 7 machine and still did not get the crash to occur.

I suggest testing this issue on a different machine as well, in a new clean project to see if it occurs there as well. If you are able to get it to crash, please let me know and provide us with the same information. At this point, I have all the information I need from you to generate the bug report, but unfortunately cannot move forward with the process until we have a reproducible case to test against.

If you might have forgotten some steps in order to reproduce the issue, you can add that bit of information in your response.

Thank you,

I have a similar issue. When open a particle made by artist, the editor crashed at SceneRenderTargets.cpp, line 2218. I found it caused when engine scalability settings was setted epic. But I dont know why… Please check this why.

Hey history1213,

In order to effectively assist you with your issue, I am going to need some more information. Please take a look at our How to Report a Bug sticky on the Forums to get an idea of the information we will request from users when writing an official bug report.

Let me know if you have further questions.