Depth of Field with Sequencer Camera

Steps to reproduce:

  1. Add camera in sequencer
  2. Select camera and add post process → Depth of Field, Gaussian, set blur to very high for near and far.
    Result: no blur gets applied.
    Expected result: DOF blur should work just like in the normal camera without sequencer.

Hi aliasense,

I was able to get DOF working in sequencer. I just used Near Blur Size for my test and could get the sequence to play as expected. Please look over the documentation and make sure that you are using the appropriate workflow. Here are some resources that can be useful.

I have a feeling you may not have key framed something correctly, or you didn’t play the sequence using blueprint, or you aren’t possessing the camera being animated in sequencer. These are just things that could possibly go wrong I’m sure you just missed some small step that will be easy to fix. :slight_smile:



Hi Ed,

The sequence plays and also all the other camera parameters e.g. White Balance → temp get applied correctly and immediately in the camera preview.
Which platform did you test on? Linux?

The DOF settings works fine on the normal camera, but for the cinema camera nothing happens (though again all the other post effects seem to work like color grading etc.) Why would only DOF not work and all other effects work properly?

There seems to be some other people with the same issue: depth of field not work cinematic camera 4.12 - Cinematics & Media - Epic Developer Community Forums


I didn’t know you were using the Cinematic camera. This is important because the DOF settings are disabled by default. To use DOF in the postprocess you need to set the focus method to “none” (see screenshot) or the camera will ignore your DOF settings. Doing this should allow you to use DOF with sequencer as well.


I also modified this answer and applied it to the other post so those people can benefit from this info as well.

Let me know if that helps!


, Ed. Changing Focus Settings-> Focus Method to none did the trick. It might be an idea to put some sort of warning in the sequencer or the cinema camera. We did not know and were just surprised by the different behavior. Hope this helps. again

I’d also add that “none” is no longer an option for DSLR Universal Zoom cinematic cameras; I’m not sure whether the modern equivalent is “Disable” or “Do Not Override”

I’ve had this issue too! And I’ve seen a lot more posts with no resolutions. Did you ever find a fix? I can’t get a cinema camera to use DOF at ALL, even in an unedited base default test scene