Download

Depth of Field / Transulcent Materials Problem

Hi Guys, after setting the depth of field in my scene I noticed that any object that is next to an object with translucent material applied (all the windows in the scene) the depth of field looks sharp and it does not blur out the same way everything else does (The metal frame decor around the windows). I tried the glass material with and without opacity but maintaining the material blend mode as translucent but the result is the same as shown in the image attached. This problem happens in the two depth of field modes I tested (BokehDOF and CircleDOF). Anybody knows the reason why this is happening and any idea on how to fix it?

Im using Unreal 4.20.3

Thank you all for the help!

Fabio

Unreal 4.20.3

1 Like

I’m also wondering about a scene with “holograms”, which are not affected be DOF. Did you find out something?
(I’m in UE 4.26.2)

If by “holograms” you mean meshes with translucent materials, then you need to turn off Render After DOF option in that material. This will allow for a translucent material to be affected by DOF effect.
Of course there is couple of implications for turning that option off. First, you wont be able to use Sort Priority feature on mesh with it. And DOF on complex translucent materials can seriously affect performance.