Depth of field on translucent material?

My translucent/additive materials do not seem to be affected by depth of field. Any ideas?

Go to your material, under Details panel > Translucency unclick Enable Separate Translucency.

1 Like

Thank you!

Hi! Enableing separate translucency made the effect(ember) be affected by DOF but it seems as if depth of the particle is read by scene depth. If I hide all the other object in the scene, particles DOF correctly, but with other static meshes rendering, depth of the particles are all wonky. Help?

DOF does not work correctly with translucency afaik because translucency is not written to the depth buffer. Enabling separate translucency will make the material ignore dof and will not work with it.

Thank you for the quick answer.

I know that, however, in udk3 there was a simple solution to the problem just had to mark some option in the translucency ticks.

There no solution to that at all?

Well it doesn’t solve the problem, unchecking it gives it a dog of the bc behind it. Meaning if there’s no object it gets the horizon depth.

I can’t find any solution either.

I had said unclick that property. It is enabled by default so you need to disable it.

Can you post a screenshot of what you are getting please?

Sorry it took me a while here it is
as it is shown in the picture, the depth of the translucent material is taken only from whats behind and not its real place

Weel’ any news?

I have similar problem here - Gaussian DoF on translucent material - Rendering - Epic Developer Community Forums

But still no correct solution.

you shall really vote him up and mark his answer as solver if he helped you…

I’m still looking for a solution to this also. I actually couldn’t find the Enable Separate Translucency checkbox in the details panel.

It’s now "Render After DOF"


Brill. Thanks for that. Big help

So got around this by doing what foliage shaders do, I went to investigate a random foliage material, saw they were using a Param2D node that had inside it a Material Expression Texture Base with a slot for opacity mask, boom copyed it and connected to my material opacity slot with he texture I used for mine and it worked…
Unfortunately I never found “Go to your material, under Details panel > Translucency unclick Enable Separate Translucency.” tip, and it may be depricated or I am just not looking the the right place…

1 Like


Would you explain how you did this? I ticked the “render after DOF” mentioned before, and it does get affected by DOF however it is the incorrect DOF. It is treated like whatever is behind it :frowning: I would like to try what you’re saying but don’t know how to… How do I get a Param2d node, and a Material Expression Texture Base… video maybe?


1 Like

Under Translucency > Advanced – Changing Translucency Pass to Before DOF , fixed the issue on my glass material.