Deformed Mesh TAA Ghosting Issues

I have a deformable mesh that is drawn using a custom proxy. It seems like the velocity is not accurately filled, because I’m seeing TAA ghosting artifacts. Strangely, they are only visible in shadowed areas - lit parts of the mesh look ok.

Is there any particular step required for velocity to be accurately computed per pixel for deformable mesh?

Any tips and pointers appreciated.

If its deforming via WPO, make sure WPO is outputting velocity in the project settings.
In some cases you may need to make use of the “Previous Frame Switch” node.

Also try setting the actor to moveable instead of static.

That’s not usually the solution but there’s a bug in 5.0 where static meshes using WPO animations aren’t putting out correct motion vectors unless set to movable, not sure if it’s happen with other actors or in other places.

Thanks for the replies.

I am not using WPO at all. The mesh is deformed on CPU - basically every frame a new vertices are updated. This will be moved to compute shader eventually, but it doesn’t change the way the mesh is deformed.