deferred decals not visible on shadowed surfaces

I have a deferred decal with an alpha channel which I’m using for bullet holes. It works on surfaces that are well-lit. But they don’t show up at all on any surface that is not receiving direct lighting. Is there a fix for this?

Are you using dbuffer decals?

No. I’m using the regular translucent decals.

Try dbuffer decals.
First activate it on Project Settings > Rendering. Then, change it in material.

I tried dbuffer decals and unfortunately they don’t show up at all.