DefaultPawn mesh is hidden when possessed by player

Is the DefaultPawn’s mesh supposed to become invisible when possessed by a player controller?
If it is, is there a way to disable that behavior?
If it is not, any suggestions on how to troubleshoot the issue?

In my own troubleshooting, I created a blank blueprint project, set up a GameMode with the default pawn class set to a slightly modified DefaultPawn. The only modifications are a SpringArm and Camera combination that pulls the player’s view away from the pawn’s mesh. (300cm length, third person style to prevent camera clipping.)

I then dropped two pawns into the level and assigned one to auto-posses the player. They are positioned close to each other but not overlapping. When run, the pawn that is not possessed by the player behaves as expected, its sphere mesh visible to the player camera. But the mesh of the pawn possessed by the player is invisible to the player camera.

I have searched through all the visibility related settings I can find, such as Rendering > Visible and Hidden in Game. They are all as expected. Anywhere else I should be looking?


No is not normal this behavior… Are you really sure your camera is outside the mesh? 300 cm would be enough…
…a transform /rotator accidentally setted?

When you run it in the editor, press the eject button and you will be in a kind of spectator mode. Move around the level and see if your possessed pawn mesh is showing up. If it is showing up, there might be issues with the camera and spring arm setup that you did. If you don’t mind, please share your project files. I will take a look and see if anything is wrong.


RE: Eject: Ejecting results in the the mesh becoming visible. (No change in view position.)
Lengthened the spring arm to 400. No change.

Attached is the troubleshooting project. Steps to repeat:

  1. Open the project. (Will open the troubleshooting level.)
  2. Note PlayerX and PlayerX2. (PlayerX will be auto-possessed by player.)
  3. Click play. PlayerX will disappear.

link text

In the PlayerX Blueprint, click on the “MeshComponent”. Turn “Owner No See” to False. You will see the sphere.


Dang it. I knew I spotting a setting like that a couple days ago. But then I could not remember the name and decided I was mistaken. Thanks much BladeMaster.

You are welcome!

Answer credit is to BladeMaster. (See the question’s comments.)

The DefaultPawn’s MeshComponent is configured to be hidden when possessed by the player. So the behavior is as expected with the pawn’s default settings. To change this behavior set “Owner No See” to false. It is located under the MeshComponent’s Rendering section. If you browse manually, you’ll need to expand the section to show all options. Or you can get to it quickly by searching for “owner”. (See the example provided by BladeMaster.)