DefaultGameUserSettings.ini not functional anymore?

I brought my game project (BP only) over from 4.4.3 to 4.5.1 and now when I package it (haven’t changed anything), all things that I setup in the DefaultGameUserSettings.ini aren’t recognized anymore, again worked just fine with the previous version. Any ideas folks?

Content of the .ini file:

[/Script/Engine.GameUserSettings]

bUseVSync=True

ResolutionSizeX=1920

ResolutionSizeY=1080

bUseDesktopResolutionForFullscreen=False

FullscreenMode=0

Hey The_Distiller-

When you say that they’re not recognized are you receiving an error message when you try to package? Where are you running into problems and what exactly is happening when you do? The more information you can provide the easier it will be to solve whatever problem you’re having.

Cheers

Doug Wilson

There is no error, but the commands of the .ini are apparently not executed anymore, since the packaged game doesn’t start in fullscreen and at 1080p. Which it did when compiled with 4.4.3.

Having the same issue. Before I could use DefaultGameUserSettings.ini or just change GameUserSettings in the WindowsNoEditor build folder to set start resolution and fullscreen on launch. No longer working.

In the project folder, go to the Saved → Config → Windows folder and open the GameUserSettings.ini file. Copy the contents of the file and replace the contents of the Saved → Config → WindowsNoEditor → GameUserSettings.ini file of the packaged game. Make any changes to this file and save it before launching the packaged game again.

Cheers

Doug Wilson

When I do the exact steps listed above and launch the cooked game, the GameUserSettings.ini get’s cleared, hence when I open it after launching and exiting the cooked game, it’s empty.

I found a procedure that works:

  1. Start the cooked game and enter full screen mode manually via alt+enter, exit the game. (This will fill the former empty GameUserSettings.ini)
  2. Go to saved → config → WindowsNoEditor and open the GameUserSettings.ini
  3. Change the content to your preferred settings, for me it was activating vsync and set the resolution to 1080p.

Sorry for bumping here. I got same issue. It seems that UE4 doesn’t save anything into config files under “Saved” folder anymore since version 4.6. My question link is here, that haven’t been answered yet : [link text][1]
[1]: ,Why does UE4 save nothing into config files in "Saved/Config" folder now? - Platform & Builds - Unreal Engine Forums

Another option would be to make a shortcut to the executable and add command line arguments

It would be great to have the default resolution settings for the packaged game available in the Project settings in the editor.

I was surprised that the Editor settings for “Play in Standalone Game” didn’t carry over to the packaged game, but even the “play in stand alone game” section doesn’t have a fullscreen option. I had to add “-fullscreen” in Additional launch parameters to get the game to be fullscreen there.

It would be great to have a fullscreen option in the play in standalone game section in the editor.

41122-fullscreen.png

Hi, after trial and error I found that DefaultGameUserSettings.ini does indeed still work but no longer in the saved folder. Instead you need to put it in:

WindowsNoEditor/ProjectName/Config

This is what worked for me. I realise this question is quite old now, but I’m sure there are plenty of people who are still having this problem.

Hey I am following the same procedure but my GameUserSettings.ini does not fill

That doesn’t work for me in 4.8 – I created that folder in the packaged project, added the DefaultGameUserSettings.ini file, but nothing is changed, those settings are not set when launching the game :frowning:

I just gave it another try in 4.8.3 and it works right away. You shouldn’t create a folder, instead you have to execute the game once and the folder will be created automatically. After you opened the game once, make sure you overwrite the GameUserSettings.ini in the correct folder.

For this test I called the project “fullscreen_test”.

So the correct path is: fullscreen_test → fullscreen_test → Saved → Config → WindowsNoEditor.

I attached my GameUserSettings.ini to this message.link text

Thanks for the feedback!

I figured out the problem painfully.

My unreal version: 4.8.3

Yesteday I tried Saved → Config → WindowsNoEditor → GameUserSettings.ini and DefaultGameUserSettings.ini both but neither worked for me.

Finally today I found that, in DefaultGameUserSettings.ini:

[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=640
ResolutionSizeY=480
LastUserConfirmedResolutionSizeX=640
LastUserConfirmedResolutionSizeY=480
WindowPosX=-1
WindowPosY=-1
FullscreenMode=2
LastConfirmedFullscreenMode=2

The above ini failed. But if you add Version=5

[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=640
ResolutionSizeY=480
LastUserConfirmedResolutionSizeX=640
LastUserConfirmedResolutionSizeY=480
WindowPosX=-1
WindowPosY=-1
FullscreenMode=2
LastConfirmedFullscreenMode=2
Version=5

It works. I really don’t know what is the meaning of this Version=5 thing

Thanks, the Version=5 line was what fixed my packaged build default resolution issue. I created “DefaultGameUserSettings.ini” in my Config folder instead of modifying “GameUserSettings.ini” in Saved/Config.

I wrote a short tutorial on this matter some time ago. Maybe it is of some help for you: https://impetus-games.com/blog/Persistent-Graphics-Settings-in-UE4

From the UGameUserSettings documentation:

“Version: All settings will be wiped and set to default if the serialized version differs from UE_GAMEUSERSETTINGS_VERSION”

So if you don’t have the version properly setup in a DefaultGameUserSettings.ini it will think they’re out of date and erase them. Thanks for this fix!

Hmm, I guess it would be too much to ask Epic for a way to tell what version I should use inside the editor? Hell, would love to have a “default settings” part in the project settings so that I don’t have to “guess” the contents.
Lazy I know but since it either works or not sorta annoys me.