Download

DefaultEngine.ini ignored in package project

Hi!

Working on my VR project I detected an issue testing a package project: the game looks worst than the game in the Unreal Editor. There are some things that are not working properly but the most important for me is the ScreenPercentage.

My DefaultEngine.ini file has this line:

[/Script/Engine.RendererSettings]
r.ScreenPercentage=150

But as I said when I open the generated .exe file doesn’t looks like 150% so… I checked the log file and I saw this:

[2016.09.14-10.28.53:760] 0]LogConsoleManager:Warning: Setting the console variable ‘r.ScreenPercentage’ with ‘SetByScalability’ was ignored as it is lower priority than the previous ‘SetByProjectSetting’
[2016.09.14-10.28.53:760] 0]LogConsoleManager:Warning: Setting the console variable ‘r.PostProcessAAQuality’ with ‘SetByScalability’ was ignored as it is lower priority than the previous ‘SetByProjectSetting’
[2016.09.14-10.28.53:760] 0]LogConsoleManager:Warning: Setting the console variable ‘r.LightFunctionQuality’ with ‘SetByScalability’ was ignored as it is lower priority than the previous ‘SetByProjectSetting’

Any idea to fix it??

THanks

I have the same issue, does anybody know how to read config in package build?

same issue here! if anyone has any idea…

edit: lol, delete the logs in your project save folder. (I just deleted the whole save folder, but then again, I don’t have Favorites, or care if my window positions get reset)

When you manually override a console variable, anytime you try to use a scalability settings that modifies this variable, it will look through the log and see that you manually changed it, and prevent scalability from resetting it.

Weird.

You can use %USERPROFILE%\Documents\Unreal Engine\Engine\Config\UserEngine.ini for your packaged project.