Download

Default tonemapper that can not be turned off?

Hi,

I just found out that UE4 has enabled filmic tonemapper by default even when you have no postprocess volume in your scene and even when you disable all the things in the defaults rollout in rendering tab of project settings. I find this a bit concerning as this is not something user is aware of.

First of all, I do not understand why some of the default postprocessing settings can be toggled off in the project settings, but others can not…? Why can I turn default eye adaptation, bloom, motion blur, lens flares, but can not turn off default tonemapper, when it’s the exact same kind of controversial default?

Secondly, if I ever wanted, for whatever reason, to have completely linear output without any tonemapper interfering with it, how would I go about it? I can not seem any combo of the tonemapper settings that make image completely linear.

Lastly. It appears I can turn off tonemapping for the viewport by going to show>postprocessing>tonemapper. This has two issues though:
1, It disables not only default tonemapper, but also any tonemapping from postprocess volume. So if I wanted to start with linear image, and actually see how tonemapper affects and changes the linear image, I have no chance of doing so.

2, This will likely work only in editor. If I build a standalone executable, it seems there is just no way to get rid of tonemapper.

Am I missing something?

Thanks.

No youre not!^^
There are actually several threads with people complaining about this and the lack of alternatives. The problem here is: Epic doesnt respond at all! Its super frustrating, but the same is going on for the new physical lights and exposure controls. No one gets them, the defaults are weird, everything feels kinda broken and no one from Epic replies to concerns or whatever.

Its quite a bad situation for some people right now and I truly hope Epic will respond at some point. I know it wont be easy to have this discussion with the community, but they cant dodge that bullet forever. Just fucking talk to us and get that shit sorted out so everyone can be calm and happy again :wink:

Some people though say that will never happen…and as there is still no answer from Epic in regards to the broken physical lights in 4.19…I am slowly leaning towards this impression as well T_T

Cheers! :slight_smile:

  1. You can’t turn off the tonemapper because 99% of the uses of the engine require a non-linear image. You’re the first person I’ve seen wanting to see a linear image, compared to the dozens of people just complaining about the look of ACEScg. It’s default, because everyone is viewing the image on a Rec.709 or Rec.2020 display.

  2. The tonemapper is starting with the linear image to convert it to a display-referred space. I don’t think any amount of the available tonemapper tweaks will get you back to a linear image. There is a G-Buffer view for Pre-Tonemap HDR color, that should be your Linear image. However, I don’t think that’s necessarily what you want? The Scene Color/Final Color/Post-Tonemap HDR colors might be closer to your liking?

  3. A lot of the color grading is done with the same tonemapping process since the grading is done in the same scene-referred linear space. You can’t separate them out to my knowledge, even with the old tonemapper.

Well,

the reason I would want to get linear is to have some starting point of reference, so that I don’t feel so lost in space. In offline rendering, I start with linear image, and I apply filmic tone mapping to my liking, but I know how did I get there. If I for example use EXR environment map as my background, then at starting point, that map looks exactly like in Photoshop, when I open it. Same goes with pretty much any texture data. Filmic tone mapping is just fine, but not being able to get to linear is what I have problem with.

An example where it causes practical issue is LUTs. I have loads of LUTs that are supposed to be applied onto Linear image, and transform them into some film look. Since I can not get linear, or override filmic with that LUT, basically entire my LUT library becomes invalid. The LUT won’t look the way it was supposed to with another layer of Filmic tonemapping on top of it. And if I go to Show menu in the viewport, and disable tonemapping in the list of postprocessing controls, then it disables the LUT too, since it is too considered a tonemapping feature.

What you want to do makes sense, I just haven’t seen anyone else request it :smiley: Have you tried those views I mentioned, at least as a visualizer to start with?

As far as the LUT issue goes, yeah that’s a problem area for everyone currently, but for a different reason. Epic might be phasing out LUTs altogether based on their recent updates to the color grading suite anyway, so no idea on what to expect in the future. It’d be nice if they supported LUTs in scene-referred linear as well as .cube formats.

The only thing I can think of is applying an inverse tonemapping in a post-process material set to “after tonemapping”, but with ACES the math gets a lot more complex. Might be worth looking into though

I personally would love to have just another value in the filmic tonemapper which would blend ACES tonemapper with linear. It would default to 1.0, which would mean full influence of the ACES tonemapper (in the same way LUT has influence slider), so nothing would change from the current behavior by default, but if someone actually needed to disable ACES tonemapper, or would like it to not have 100% influence, such slider would be useful.