Default Preview Rendering Level

Hi, sorry if this question is already answered, i couldnt find a proper one that could help me with this doubt, so…

I’m currently working on a vulkan project using the preview rendering level of:

High End Mobile/Metal > Android Vulkan Preview
I wonder if there is any way to set this one to the default preview rendering level, because each time that i open the editor it starts on the default Shader Model 5, and often i dont notice this till some time later, is kind of annoying to switch it every time that i open this project so im here :smiley: thank you for the help you could bring me!

Almost all editor settings can be found in appropriate config file (ini).

Maybe there is something in DefaultEditorSettings.ini in project folder, or in BaseEditorSettings.ini in engine installation folder.

same problem here, i searched most of the config files, but didn’t find anything. however, if you go to project settings → supported platforms and uncheck all (not android), it could work.
Or under project settings → platforms → windows/linux uncheck every “targeted RHIs”.

For me, those settings do not work. they removed shader model 5 as a default, but shader model 4 will be the new default, and i dont know why, since no supported platform uses this.

I would love to see a “default preview shader model” thing! :slight_smile:

There is no available option to be set that has been exposed.