Default Convolution Kernal Blurring

Hello. I am using Unreal Studio 4.20 and trying to get the Default convolution kernel to work. The documentation states: “Bloom is a whole image filter, so with Convolution Bloom the hottest part of the image should be the considerably brighter than the rest of the image (.exr format works well for this), otherwise the filter will have a strong blurring effect over the screen.” I understand this but what I dont understand is why the default texture still blurs my entire screen. I’ve checked it in Photoshop, 32bit mode, and it’s very clearly hot in the center and less bright at the edges. I tried making my own temporary texture that is also very clearly hot in the center and black everywhere else and it still seems to blur my screen. Is this a known issue for Unreal Studio 4.20 or is there something I am missing here? I’ve been through almost every forum thread and video tutorial I could find on how to use this bloom effect and it always turns out blurry for me. Any help is greatly appreciated.


I found a solution

Try to adjust Convolution Center value. For default convolution texture, value is (X=0.499770,Y=0.500230) worked for me. Try to setup values with witch screen that will not offset.

For quick comparison of results, I just set Convolution Scale to 0 and toggle (click-click) override value check box that setting it to default value 1.