Dedicated Server Public IP Connection not working

Greetings Dev,

I am currently working on a Dedicated Server, and while I am able to connect on LAN, I can’t seem to be able to log into the server remotely. I have a laptop on a different connection that I’m attempting to use as a potential client but it doesn’t seem to be able to establish connection. I attempted with ClientTravel to Servers public IP and with the Open command / function feeding it the Public IP and its not working.

I was wondering if there is anything else beside port forwarding the Private Static IP Address that I might be missing on the routers end or something to enable the connection.


I think I was able to confirm the issue is on my internet… I recreated a dedicated server following the guide and was not able to connect by changing the Open to my Servers public IP address… not sure what else besides port forwarding I might be missing.

Was able to confirm issue, it was the ISP that was blocking the ports by default, submitted a request for the ports to be open, next day everything is working fine.

So for anyone struggling with this type of issue, this is an easy list to glance over:

  1. Port forward to your Private Static IP Address on your Routers setting.

  2. Make sure both the Routers and the Windows Firewall are not blocking the ports. First try turning both of them off to make sure that the firewalls are the issue, if they are… Create custom Inbound / Outbound rules to make sure Firewalls allow connection.

  3. Try a DMZ.

And finally if all of the above fails, make sure to contact your ISP and confirm if the ports are closed. I had once already used Dedicated Servers over the internet but I had changed Routers since that moment, and as the IT department at my ISP confirmed, every new router needs to be adjusted on the ports. So even if you had it working before, make sure its not a new router with the ports blocked by default.

Anyways I thought I’d leave this here for any struggling Developers out there.

Happy Dev’n and Much Love!