Dedicated Server built wrong


After a longer time, I tried to build a new dedicated server for our project. It used to work fine, but it does not anymore.

When I compiled the server in VS2013, it placed the server files in the binary folder of my project. I then had to move them from there to the binary folder of the packaged game in order to get both working.

When I compile it now, it places the server files in the binarie folder of the source engine itselfe, where also the editor exe lies. When I move them from there to the packaged game, the server just does not working at all. It just doesnt do anything on open (its not in the task manager, shortcut with -log does not help)

The compilation in VS2013 works without error though…

Anyone has an idea why? Or a different method of getting a dedicated server exe up and running?
I never managed to do it differently…

So I would propably need a step by step guide (Not the ones you can already find in the web. I know the steps itself.)

I attach the servertarget.cs . If you need anything more please do tell so.

link text

Oh and when I run the server.exe in the engine binaries folder I get a crash with the following:


Access violation - code c0000005 (first/second chance not available)

Fatal error: [File:C:\UnrealEngine-4.7\Engine\Source\Runtime\Launch\Private\LaunchEngineLoop.cpp] [Line: 275]
Non-agnostic games on cooked platforms require a uproject file be specified.

BattleArenaServer!FMsg::Logf__VA() + 479 bytes [c:\unrealengine-4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:523]
BattleArenaServer!LaunchSetGameName() + 391 bytes [c:\unrealengine-4.7\engine\source\runtime\launch\private\launchengineloop.cpp:283]
BattleArenaServer!FEngineLoop::PreInit() + 562 bytes [c:\unrealengine-4.7\engine\source\runtime\launch\private\launchengineloop.cpp:687]
BattleArenaServer!GuardedMain() + 235 bytes [c:\unrealengine-4.7\engine\source\runtime\launch\private\launch.cpp:110]
BattleArenaServer!GuardedMainWrapper() + 26 bytes [c:\unrealengine-4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
BattleArenaServer!WinMain() + 249 bytes [c:\unrealengine-4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
BattleArenaServer!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Have you tried running the server executable from within the packaged directory on the command line? I would be curious to see its initial output on the command line.

Open a command prompt (I think that’s what windows calls it) in administrator mode. In windows 8 I have to press the windows key + x to present this option from the desktop.

Then cd your way to your binaries directory in your packaged game’s folder and try running the MyGameServer.exe -log command.

Can you elaborate the steps?

I copy the 4 server files (including the exe) in my packaged binaries folder, run the command line from there and input what exactly?..

It also does nothing…

It jumps right away to the next line, nothing openes. (Like when I double click it).

I managed to get rid of the problem. It apparently was because of my servertarget.cs (allthough I am sure, that I used that one the whole time, even when it once worked).

Anyway, the new server target is attached:

link text