Dedicated Server 4.22 ShooterGame connecting

Hey guys, I have been trying to get a dedicated server running with the default ShooterGame project in 4.22.
I have followed all the docs and wikis I could locate. I have got it to build and run successfully, however I can not get it to connect or even see the server.
I got the 4.22 release branch from github, compiled and got that running. I created a shootergame project with the epic launcher and pointed it to the installed 4.22 from the launcher. I then changed it to the github version, recompiled everything, all of that works. I can run ShooterGameServer.exe -log, I can run ShooterGame.exe standalone.
I can even host a game from ShooterGame.exe and join that server with another ShooterGame.exe. The problem is that ShooterGame.exe never sees the dedicated server. I try the server browser, I also tried directly connecting via “open” and the actual IP of the same computer on the network.
The directions I followed that worked the best were here, How To Set Up Dedicated Servers for Windows and Linux For Your UE4 Game (using Windows)
I also followed this one with the same result, A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Does anyone know how to get it to connect?
My log file for the server is attached, the only thing I see in it that makes me question is this: “LogOnline: GotoState: NewState: MainMenu”
does the server need to be put into a game state other that MainMenu?
ShooterGameServer log

I can not get my shootergame project to see dedicated servers in the menu either, also removing menu items like “Host Game” since i am doing dedicated servers is a pain in the butt…everything else so far with the project is awesome but this slate main menu is a pain in the backside…Removing it is even more painful…

Any ideas on how to remove the menu so i can just make one in UMG?

Having same issue here, looks like the dedicated server didn’t start a map.