Download

Deceivingly Simple Emissive Colour Problem

The yellow emissive colour is not lighting the area around it. After google searching for over an hour I’ve decided to come here for help.

Possible causes and clarifications:

  1. I’ve ticked the “emissive (dynamic area light)” setting in the material.
  2. I’ve ticked the “use for emissive static lighting” setting on the 2 objects in my scene.
  3. I’ve multiplied emissive colour up to 10,000 for testing purposes.
  4. I brought in a LightmassImportanceVolume.
  5. I’ve been baking light at production quality.
  6. I have separate UV’s for lightmaps.
  7. My meshes are set to static.
  8. My scene is about scaled 10x higher than the norm.
  9. I’m using vertex colour to control emissive colour.
  10. I’m using UE4 4.13

Why is my emissive colour not lighting the scene?

Emissive color does not light the surrounding area unless using lightmass with “Use Emissive for Static Lighting” or if you have LPV enabled for dynamic indirect lighting then the “Emissive (dynamic area lights)” option will work.

Emissive for static requires a higher lightmap resolution to get good quality and requires a higher value for your emissive input to produce enough to get a good single bounce of light. It’s better to use some point lights and fake the effect you’re going for. The Emissive for static option shouldn’t be a method for achieving a lot of lighting in your scene. Without high emissive values for a scene like this I wouldn’t expect to see a bright result without them.