Decals do not render properly on emissive materials

Is there a way to get around this?

This is what I get on a material with an emissive output.

This is how I want it to render but removing the emissive is not an option as the visual style I’m going for relies on it.