Decals Become Transparent as Additional Decals are Placed in Level

Hi, thanks for your great engine!

I have simple question: Some of my new placed decals goes to be transparent more and more with every new decal (While Im not started to make a new level) At the end I can see normal map only :slight_smile: Is it bug or I missed something in decal configs?

Here is some screens. Thanks!

PS. Materials and alpha map don’t matter. Same textues works great in UDK.

What is your decal blend mode set to in material editor?

Here is my material settings.

You need to switch Decal Blend Mode to Stain if you dont want it to be translucent.

Thanks for the answer! I’ve tried this before and now, but with same results. Nothing changed :frowning:

You are right. I’ve just tried myself and something seems to be wrong with decals. :\

Hi Sergey Shemet,

Try multiplying your opacity texture by a constant (1). If that works play with that number until you get the specific degree of opacity you are looking for.

Let me know if this helps!

Adam

Hey Adam!

I’ve tried it both with a decal material from the beta(using an alpha) and a constant 1 directly plugged into opacity, and neither is giving the expected result with Stain blend mode. Also tried multiplying the alpha with a constant 10, but still get the same half opaque look.

Thanks for the answer!
Unfortunately, still dont work. Multyplying makes Normal texture darker.
And this don’t work without opacity texture.
Sometimes i see material of decal (but transparent), when change material below decal (on the floor).
And I don’t see opacity texture in material preview.

Would you mind posting some screenshots so I can replicate the results here? I am having a difficult time getting anything that looks similar to what has been described thus far.

Thank you!

Adam

False alarm on my side, sorry!

Apparently my scene’s lighting is broken somehow(I’ve been using the same scene to test stuff for a while now and i had enabled LPV the other day so that may be my problem, even though it gave the same result with LVP disabled in directional light) It is working fine in other maps.

Sergey, i suggest trying the decals on a new level and see if they work.

Works well on new map. But I make a new huge level and need decals here :slight_smile: I have only 3 or 4 simple point light in map

Something I noticed with mine just for future reference, if the decal box is low to the ground it appears more transparent than those with the box higher up (so that the bottom of the decal box is either directly on top of or into the ground). This may be something to look at as well if it continues giving you trouble. I am glad you found a solution to your initial problem, however!

Thank you and have a great day!

Adam

Thanks for idea. Working in existing level with spotlight. But, what is LPV and why this dont work with pointlight :slight_smile:

LPV is an upcoming lighting system that can be enabled via a console command(You can find more info about it in the forums) So if you dont know what it is then you dont have to worry about it on this matter.
I don’t know why it is not working in your case though. If it works properly in a new map with point lights then i suggest starting with a new map just in case you may run into such an issue again in the future.

I’ve been banging my head against this same problem for the last few hours. It seems that if you have a skylight in your scene, that skylight takes precedence and some of your base material bleeds through your decal. Is there a way to mask out the skylight contribution with the decal? Or is this a bug?

Hi chapes,

Here is a link that may be able to assist you. Try the solution presented here, if it does not work please let me know and we will continue:

Thank you!

Hmm, I’m not exactly sure how to go about implementing that (where are the system settings?). But I’m not sure if that case applies to my situation.

Basically, my decal is in direct light (directional). And it works. But when I add a skylight to the scene, the decal changes to transparent showing some of the material underneath. I have tested it with a simple all black material with full opacity and I get this result. Works without a skylight, doesn’t work with a skylight. Is adding a skylight the same as being in shadow?

thanks!

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

Actually it’s issue with static lighting and deferred renderer. IF you will be using only dynamic lighting this will not be issue.
If you want to use static light and translucent decals, you will need to enable dbuffer.

find ConsoleVariables.ini in Engine/Config and add this line:

r.DBuffer=1

In material editor you can find various DBuffer Translucent, something, something. Set to one of these.