Download

Decal Cast White Color with normal map on!

This is the decal material :
DecalMaterial.PNG.jpg

The white color can be seen most on metallic materials. as you can be seen here :
DecalNormalCastWhiteColor.JPG

Is there anyway to fix it ? it looks a lot better with the normal map on.

Hello,
According to the decal map in the content example project. at 1.2 decal blend modes : Translucent and normal are the only modes that can use a normal map texture. And your use stain.

This one is with translucent, the same issue :
60a4465c7fd6b75de8f3e5e0cbee849135762413.jpeg

Sad it was not only that. I tried to do your material set and first i got nothing by using alpha but i got it some by using white output for base color texture sample. And i saw different effects by using or not tangent space normal. Have you try those ? And is your normal fitting your texture. They seem different and the white around area seems outside of the normal map modifications.(but as it is small, i don’t know) in hope those ideas help you more…

Thanks for testing it yourself! very appreciated.
I use alpha because the texture i’v made has it’s data on the alpha channel ( black and white ). so i had yo multiply it with the right color.
The normal map was made right out of the original texture using a gimp plugin.
As you can see on the normal floor which is not metallic the normal map looks a lot better .
i’v unchecked “Tangent space normal” because it made the decal completely black (as it was multiplied by 0) when i the decal projected it’s back side (So it had to be rotated with X forward to look normal).
Did you try to project the decal on a metallic surface?

Dont multiply Opacity and normal map.
Unplug Specular.
Enable dbuffer decals.

And see how it goes now.

Have any idea why when i use some method no matter which one from the DBuffer, it gives me nothing at all ?

I’m not sure. Make a decal with Epic’s textures and see how it works. If it works then there is something wrong with your textures.

Ok i got the DBuffer to work with the help of this thread :
https://answers.unrealengine.com/questions/25508/decals-not-rendered-without-direct-lighting.html

It helps if i want to use diffuse only. the non DBuffer options didn’t project on some places with baked lights, and this one does.
But for decal with normal maps, it looks the same :\

Ok i’v got it solved !
There is a value that needed to be raised :5cff78506f259f43957570445c3b4eef45c647f6.jpeg
I raised it from 1 to 20 and it made that extra white color to go away.
It is changing the general look of it as well, but that can be tweaked in the material editor.
Thank you everyone who helped me! I hope this information will be useful to users :slight_smile: