Debugging multiplayer game


I’m designing a multiplayer RTS that uses the Steam OnlineSubsystem. However, when I connected two computers, it didn’t have the same behavior as in the editor…
I later learned that the editor is not a good place to debug multiplayer games but as I think the multiplayer causes the problems, is it possible to debug the game via the standalone option?

As this game is only a POC I’m using save games to transport the data between levels but testing in editor, I only have one computers so both games use the same save game. I’m trying to separate clients by the isServer boolean but it remains the same…

I have tried to do it by not using singleprocess, desactivating the online subsystem (using the null one) and placing the listen command for the server and -game -debug for the commandline. However, my breakpoints are not hit.

Can anyone help me?

What exact issues are you running into? What differs between Editor and Packaged? Logs?

You should be able to debug games in PIE for multiplayer (99%of the time, more on that later), adding the number of players needed. Steam testing, is more making sure that players can create/join sessions, and you do that in packaged builds since you can’t do that in PIE. But yes, you can test that out in Standalone. Steam overlay popping up.

While there should NOT be any difference between packaged and editor, there ARE a few instances where there are, due to how the it compiles/builds the games in PIE/Packaged. I’ve run into a few of those issues before. Pretty sure it was HUD that got me good. Basically how my widgets were being created and inputs were being processed. In editor it worked fine, packaged did not. Had to redo logic a bit to make it work in packaged, you may have to do the same depending on the exact problem.

The problems I’m having is on transitioning from the lobby to the main game wherer the second player doesn’t have the correct settings. another issue is the UI that doesn’t appear in either one.

The steam connection works so i will debug in PIE.