Deactivate Niagara Systems by Distance?

So I have an issue with my particle systems in the level still impacting performance regardless of if they’re rendered… in fact setting a max draw distance has seemingly no effect, and neither does setting the spawn rate to 0, thousands of particles or none at all it doesn’t seem to matter. So I assume it’s still calculating stuff no matter what. Is there any way to actually deactivate them by distance?

1 Like