Daz3D to Unreal 4/5 bridge it does not work


I use daztounreal bridge by david vodhanel (github version) for many times without any problem, but after last update (version all the time i got an error that i can’t resolve.

Every time i try to send any character (g3 or g8, simple or complex) from daz3d to unreal engine (4.26, 4.27 or 5.02, same result) with bridge, i got an error in unreal engine “Failed to find any bone hierarchy. Try disabling the “Import as Skeletal” option to import as a rigid mesh” and nothing happens in unreal engine (with previously versione of bridge the send from daz to unreal work perfectly every time with default options).

Can someone help me to solve this problem?

1 Like

I get the same message. Very frustrating. Did you find any solution yet?

Same problem here. Waiting for a fix.

David gives support on a discord channel with tons of updates and fixes. Also, it seems there is a brand new update release to all bridges in Daz3d.

I’ll see if I can find it and share it here.

Github all bridges

David’s discord:

None which work, i agree the bridge did work before a certain version now all i get when trying to export from daz3d is Access Violation Error in the QTcore4.dll.
I have checked & double checked all file settings and i can’t see an issue with the installation of both plugins that are the same version which is the most recent for Unreal, the plugin now installs stuff to the engine content folder & has a complete new setup to retargeting which also doesn’t work because the IKfoot config for retargeting doesn’t work real well when adding to the genesis skeleton 8 or 3 after resetting the bones recursively then trying to apply the ikfoot config to the new skeleton you’re retargeting animations too.
If you follow the steps using older exported characters that worked in previous versions you will find after doing all the resetting of bones & trying to retarget it results in a character that’s flopped over from the hip or is just laying on the ground in ragdoll state with no skeletal rig or pose setup, you get a list of animations that are broken with the characters body warped in different positions.
This new bridge system stinks compared to how it used to all work, now the bridge just fails & even importing the DTU file directly into the project is impossible because DAZ3D fails to export the needed data to the DTU file the intermediate folder uses to export the information from one editor too another.
When i look at the complied DTU file DAZ3D has supposedly sent to the intermediate file it has zero kb’s which means nothing has been packed into the DTU file from daz3d which when ported Unreal then says nothing is in that file when trying to read so it fails.

Or you just get this error when trying to use the bridge the normal way.

So this bridge hasn’t worked for ages since version 5 has been released.

Latest version… and it still doesn’t work.

Why not just have Daz3D compile the DTU file then send it to the intermediate file without connecting too Unreal, then from Unreal use the Import method to the file section you want just by right clicking that folder and selecting Import, the Unreal plugin side should pick the information up then convert the normal way as i have read it’s supposed to do but now doesn’t because nothing is sent to the DTU file because it crashes giving you access error violation before it complies the needed information to the DTU file in the intermediate file section of daz3d.

Hi there,

I am using 5.00.75 for UE5, and I tested it is working without error messages. I installed this version directly from DAZ Central.

Have you tried to reach the developer of DAZ to Unreal Bridge? He can help you with import settings for retargeting in Discord server.

No they don’t speak to me because they banned me over selling me content that doesn’t work i argued with there staff they have banned me from tech support the fools, they fail to reply to emails and i think they have blocked my access to using this bridge and my own paid for content and i am angry because nothing has worked since version 4.27.
I have installed daz3d many times on different drives and same resalt, access error violation in the qtcore4 dll which is something they supply it’s tied directly too there app and version.

I think the people at daz3d are children intent on breaking my stuff they sold me because how can this not work! every method i try i’m stopped by something, why is not compiling the DTU file at all?

I’ll be looking into my rights with a solicitor soon because they have stolen money from my business & now have done something DRM wise to stop me using my licensed content, i’ll be suing DAZ3D if this continues not too work because as you state it works fine for you but not me.
Sick of these daz3d people it’s always something with them.

Sad to hear it.
Can you uninstall and install again directly from Bridge?
Do you have DAZ Studio 4.20 installed?

I guess you want to go to the official version at DAZ3D.com

Here is the documentation:
how-to-unreal.pdf (daz3d.com)

Unreal Bridge 3D Models and 3D Software | Daz 3D
After adding it to your account (free purchase), you want to go to DAZ Central and install from there.

If you’re using the version from Github, here is the documentation:

Installation Instructions:

  1. Download the zipped dzunrealbridge.dll (libdzunrealbridge.dylib for macOS)
  2. Unzip and copy it into the Daz Studio plugins folder (example: \Daz 3D\Applications\64-bit\DAZ 3D\DAZStudio4\plugins).
  3. Follow the Unreal Plugin Installation Instructions to install the Unreal Plugin using the embedded plugin installer inside the Daz Studio DazToUnreal Bridge dialog.
  4. To Build Executables (aka Package Project), install the PackageProject-Dependencies file that matches your Unreal Engine version below, using the Package Project Depencies Installation Instructions.

This is my install mate ok.

I love how these help links in this panel only give you the WRONG VERSION!

By examining the Github, it seems that you’re using the latest version, newer than mine, so it can be any sort of bug going on.

I would uninstall and retry again. Make sure to close your project and UE editor, hit install plugin in DAZ Studio before exporting. Open your project again and hit export.

1 Like

I have many times, as i said i reverted to full default c drive settings it still never worked, i reinstalled everything back to d drive.

The DTU file isn’t compiling anything after you have set what morphs you want too the model; you’ll go to export the file and get this happen when using the new bridge

Just to show you i had everything working in 4.27 and managed to port those older projects to the new version 5, here are some examples of older projects that worked so you know i did have this bridge working and i do know how the file structure should work.

over 60 gb of vehicles with static & skeletal meshes, some in many separate parts.

One of 12 characters with gear i ported when 4.27 worked then migrated to 5…

These are all i can get working… previous ports.

Have you tried sending to UE427 project, then migrate assets to UE5?

Yes, i tried just using the 4.27 version but that also fails to work now because the bridge version has changed many times since.
Any setup i use 4.27 or 5 fail when porting giving me a violation access error in the qtcore4.dll file, i looked to see if i can replace that file and it doesn’t work because that qtcore4 file is part of the apps installation for it’s current version so using another one fails to work the studio itself won’t even start if i use another qtcore4 file, the QTcore4.dll isn’t corrupt far as i can tell because the studio itself has no issue running anything just the bridge has this issue when exporting.

What is supposed to be the correct file area that the intermediate folder is set too?

here i have it set to bridge/daztounreal folder but it fails to read there aswell.
does it matter where that location is for the Unreal engine to read. It was just set in the documents folder but it fails to work there now.

I followed this but with a side note

Where the plugin needs to be installed is in the plugin folder under the engine version.
In my case D:\Unreal4\Epic Games\UE_5.0\Engine\Plugins
What happened was the DazToUnreal folder was exported to another folder under the one I posted called D:\Unreal4\Epic Games\UE_5.0\Engine\Plugins\marketplace\DazToUnreal
By moving it, DazToUnreal, to the engines plugin folder UE5 was able to read it and with the plugin activated work.

1 Like

Here is where i have the plugin installed

This is where it installs when i install from daz studio the way you have stated above, thats if i just set it too engine it will throw it into plugins/marketplace/daztounreal thats installing directly into the version from the send to unreal option in daz3d.
So what you’re saying i should move this folder by cut pasting it all back into the plugin folder itself right?

I removed Dazcentral because i thought it may be loading a different version of the plugin, so i’ve just kept the old Install manager setup which has more control over files.

Try moving the DazToUnreal into the plugin folder and see what happens. I did the same thing using the git version and it works fine

1 Like

Same thing when i move that folder.
The old bridge used to have the needed daz3d files under contents in project, they are now in engine, which is much different, they are not associating any daz3d migrated stuff either.

Heres what i mean the old version used to create a daztounreal folder in the project content path.
The new plugin puts all info in the engine folder which is much different to the way it used to work.

This project here is an old 4.27 project that was migrated to 5, back when the bridge worked.
If i try to retarget this character using the new method described in youtube videos the animations do not work, i can only have the old blueprint and mannequin 4 setup i had previously made in 4.27

If I am not wrong, if you want to retarget animations to your DAZ character, first, make sure to enable the following options in Project Settings, DAZ to Unreal Settings below.

As a result of these two settings, your character will appear sideways as shown in the plugins folder (right image). That means any of your original animations from DAZ Studio will be broken, but you will be able to retarget animations to your character inside UE, as well as use IK retargeter, IK rig and control rigs provided by DTU plugin.

The only way I can possibly take advantage of DAZ figures is sending to Blender, change the rig from DAZ to UE4 Mannequin using Autorig Pro, and then send to UE. I use DTU only to send the original materials. That fix all issues with retargeting, plus I can use any control rig based of UE4 Mannequin. If my character has 52 facial ARKit morphs, I can use Windwalker Echo’s facial control rig.

1 Like

You’ll need a special procedure and extra files in order to be able to package your game for shipping (https://youtu.be/1OQ6DNPDdtE).