Download

Day & Night Cycle Interfering with Solid Sky Color

I’m trying to create a sky that will be solid colors instead of the default gradient, but whilst doing so, my day and night cycle interferes with it and won’t allow me to keep it at a solid color. It just reverts it back to a gradient. Here is the bp in my day and night cycle.

Picture2.JPG

The “Sun” variable is referencing a directional light and the “Skydome” variable is referencing the sky sphere. When I delete the node “Update Sun Direction”, it goes back to a solid sky color, but when the sun rotates, the sky is supposed to change color, but it doesn’t. When I don’t delete that node, the colors change fine, but it’s a gradient again, so something within this function is causing the gradient to come about. If anyone can shed some light on this, I would greatly appreciate it!

You probably need to animate the colors for the sun/sky. I want to say there is a Cinterp node for interpolating colors.

Hi IronicParadox,

I set up my own little thing here with the cinterp node like you said and I’ve managed to create a somewhat functioning system. It now displays solid colors, which is good, and as you will see in the picture below, I have two cinterp nodes, the first one goes from blue to orange (orange for sunset) and the second goes from orange to black. I couldn’t do blue straight to black because it didn’t get the sunset I wanted. The first cinterp node works fine (blue to orange), but the second one doesn’t work at all. Any ideas?

c5e5859d39015d8fc69f109b39d97eb675485ca7.jpeg

Pic2.JPG

From what I see, there is a problem with your clamps: The parts where it says “min angle degrees -0.25” and “max angle degrees -1 is wrong.” -1 is less than -0.25, so switch them around and that might fix your problems.

That didn’t change anything :confused:

Well either way, it needed to be changed. I would try solo testing the zenith color parameter with a single constant color; to make sure that it’s material functions are working properly. From there, if it still doesn’t work correctly, then it means that there probably something wrong with the material.

I figured it out. For anyone else that may need help in this and come across this thread, all you have to do is put the return value of the first cinterp node into the target on the second cinterp node, then set current to black. Do this both for horizon color and zenith color and it should work.