Download

Dark Spots After Lighting Build

I am just starting out in Unreal Engine, and I bought an environment pack off the Marketplace to get some practice. When I do a lighting build, I get mysterious dark spots on a mesh surface (brick wall and windows). I searched around to see what might be causing these spots, and learned a bit about Lightmass. I set up a Lightmass Importance Volume. In addition, I adjusted the Static Lighting Level Scale to 0.5 and the Indirect Lighting Quality to 2.0 (based on suggestions from a YouTube video). I set the Num Indirect Lighting Bounces and Sky Lighting Bounces both to 10. Finally I adjusted the Indirect Lighting Smoothness to 1.2 (again based on YouTube). Overall, the scene looks better BUT none of this made the dark spots go away. Any suggestions to fix this?

Screenshot 2020-09-16 172217.jpg

To further clarify, this is only happening on a Blueprint created mesh. The mesh is created by something called BP_Floor_Maker, which is a Blueprint that lets you choose number of windows, style of windows, and other variables. Other mesh doesn’t seem to have this dark spot problem. The spots only appear after a lighting build.

As a test, I deleted the top floor, which was built with BP_Floor_Builder blueprint, and built one piece by piece using the identical assets in the pack. I then rebuilt the lighting. As you can see, the dark spots only appear on the bottom floor (BP_Floor_Builder) and the top floor built by me renders correctly without spots. I assume that this is a bug in the BP_Floor_Builder blueprint tool and I have reported it to the pack designer.

It appears the floor builder BP is not generating correct UVs, or not generating UVs. The dark spots seem to be parts of the windows’ external shadows from the upper/lower parts. When placing a floor mesh from the pack (not a floor builder BP one), were lightmap UVs generated for it? The lightmap UVs can be generated by opening the mesh in the mesh editor (double-click the mesh in viewport or Content Browser, or right-click and select Edit ‘mesh-name’). Then click dropdown “UVs” and select the generate option. Make sure to set the Destination Lightmap Index to 1, and Source Index preferably to 0, and that Min LM Resolution is equal to or lower than LM Resolution in the Build settings and General settings, respectively. Without proper lightmap UVs, it’s likely to do something wrong with the shadows and/or lighting.

Thank you presto423 for the great response. I right clicked the mesh and selected Edit > SM_Walls_Top_8m_3win and that brought up an editor window. At the top of the editor window is a tab marked "UV’ and that brought up 3 choices: None (this was checked), UV channel 0 and UV channel 1 (neither selected). I didn’t see any generate option. Am I looking in the right spot? I am using the legacy user interface (recommended by people at Reallusion for use with iClone 7 Live Link). Please see my screen grab:

That is where it is located, but not in the Legacy Interface then. I’m not sure of its location in Legacy. There might instructions in an older video on youtube, or by doing a search in the doc pages it could turn up, I’m not sure. Perhaps right-clicking the mesh itself in the browser would show an option for generating UVs, or somewhere else context-specific to UVs.