Download

Dark shadows

Does anyone have advice on what to do about completely black shadows in some places after baking stationary lights? It’s only in “tight” places, like under a bench or inside a shelf, so if I turn up the intensity on my skylight everything else gets too bright instead. I’ve googled and tried a lot but I just can’t get them to be brighter without either getting everything else become too bright or everything feel washed out. I only have a directional light and a skylight, but I manage to get the whole room be bright, it’s only in these smaller spaces that it just gets completely black.
Maybe I’m missing something obvious…

Dark shadows: (lighting only)

My current settings:


Disable AO in the Lightmass settings, rebake, and see how that looks to you. Technically you don’t need AO from Lightmass because you get it naturally with static lighting, plus SSAO is on by default, so in your case you’re getting natural occlusion, Lightmass AO, and SSAO… and material AO in the final view(or Detailed Lighting).

There is also a lot of bleeding in your bake it seems, so any micro occlusion appears much larger. What quality were you baking on and how large are your lightmaps? Specifically that asset in the first image has a lot of black haloing, but that could also be the SSAO depending on your settings.

I baked on medium quality, lightmap resolution 256 each!
Turning off AO in the Lightmass settings did help, but there’s still some really dark shadows there.

Hi!

…if you’re after archviz quality…
Your settings should be:
ILLS: 0.1
NILB: 10
NSLB: 10
ILQ: 10
ILS: 0.6
…and bulid it on Production quality!

…for testing:
ILLS: 0.1
NILB: 10
NSLB: 10
ILQ: 4
ILS: 0.6
and Medium quality! It’s going to be “dirty” but will go away with higher quality when the rest of your settings are fixed!

I wouldn’t use ANY forced GI like indirect lighting intensity: they can mess up the scene!
You should turn off lightmap compression!
You should go even higher with your lightmaps! …or maybe it’s just your lightmap UV, that you didn’t keep the whole curvy part as one island but cut up into separate pieces… :S
Also you can brighten up your texture/material…
…good PP can help too…

In the directional light, these settings are probably causing some of the intense darkness:

Num Indirect Bounces (lower it to 10 or around there)
Environment Intensity (lower it to 1 or a bit lower)
Volumetric Lightmap Spherical Harmonic (lower it by at least half)
Indirect Illumination Occlusion Fraction (lower it)
Occlusion Exponent (lower it)
Max Occlusion Distance (decrease it to account for the distance between objects in the room such as 100 units between pew aisles and seats)

Under Light heading -
Intensity (lower it to between 5-9 is my guess)
Volumetric Scattering Intensity (this may be picking up texture color and bleeding / spreading it which might be darkening the tint in those objects and occluding like an atmospheric fog, so lower it)
Shadow Amount (lower it lol…)

Skylight -
Intensity Scale (lower it to 1-1.5)
Indirect Lighting Intensity (it’s at 8! lower it to 4 or 3)
Note: The thing about intensity is it can produce darker shadows, especially for an indoor scene where it is relying on indirect lighting for adding luminance. Basically, as I understand it, the first indirect light bounce is a fraction of the direct light intensity, and each successive indirect bounce is a fraction of the previous or of the initial direct light cast. So, adding more indirect bounces is likely going to intensify the first few indirect bounces’ lighting and shadowing calculations somewhat. It’s probably not the primary source of those dark shadows, but is adding to it somewhat at least.
Turn off Lower Hemisphere is Solid Color or change the color of it to white or a medium-light grey. Light from the skylight bounces off the area under the scene (lower hemisphere) that isn’t visible and gets projected into the scene. So if it’s black, it’s casting black lighting into the scene, getting plastered into and on the geometry. It caused a number of artifacts in the 3rd person template when I first opened up a level in the template. I tried a ton of things to fix the artifacts, including disabling lightmap compression, and finally when I tried that it worked and the scene was much lighter too.

As @Makigirl suggests, use a post process volume or a few even. Utilize the rendering features in the post process to enhance lighting and modify shadowing for certain areas. Lightmass portals may also help, which are said to be best placed in front of or near windows and other areas that light is entering into the room from. They concentrate the light and can yield a brighter, yet more detailed scene. Considering the type of scene it is, try getting some soft shadows in it too using distance field shadowing. There’s also self-shadow bias settings for those meshes that can be tweaked to decrease the amount of self-shadowing and correct for the darker areas.