Download

Dark shadow lines around furniture moulding after rendering

Hi,

I’ve been trying to build a level with imported assets made on 3ds max. One major issue I encountered is that after rendering, dark outlines or shadows appear around the furniture moulding, which would gradually disappear when looking closer and closer to the object, until they ( 20-100cm ) eventually disappear ( -20mm ). Shown on picture below.

I have not enable ambient occlusion and the lightmap uv have been auto generated by datasmith upon importing, and lightmap denisty mode showing mostly red so I didnt pump the res up further.

Is there any major parts I’m missing here, or it is just normal for the shadow to look abit rought when viewing from a distance?

Any suggestion are highly appeaciated

Are mesh distance fields enabled in the project or for those meshes?

I didnt check “generate mesh distance fields” in the project setting, its left unchecked by default. I mostly only tweak the lightmass setting and left all the others by their default.since I’m new to the UE4.

I have tried increasing the static lighting level scale from 1 to 0.5 but this seems to make the dark lines even more pronounced.

It might also have something to do with AO? but I cant seem to find any settings thats actually relevant

There’s settings for AO in some lights, and directional light is one with AO settings. There’s also AO in the post process volume, both regular and RT (ray tracing). Check those. Even if the setting is unchecked (disabled), it could be applied, which is something I’ve seen for a number of post process settings, but not all. What are the directional and skylight settings?

Hi!

I think if your screen messages were turned on you’d see something like “TEXTURE STREAMING POOL OVER…”
You should try typing the console command ‘r.Streaming.PoolSize 2000’ /or higher/lower number in MB/

…also I don’t know what quality you’re after but if you’d like to achieve realistic results you should try to avoid face snap meshes because it will be kind of impossible to match it with your lightmap texels and you’ll experience dark edges around those overlapping areas! It’s better to either exclude those overlapping areas from both lightmaps or just merge the 2 mesh together in your 3d app…

sorry for the late reply. Have been meaning to check all relevant settings you & makigirl mentioned above before coming back here. 1. PPV AOs have all been disable far as I can see, more way to make them any more less relevant? 2. directional light have been disabled in “affect world” setting and skylight is removed from the scene to narrow down the issue so they shouldnt be playing any role here I think

The clear issue is that most imports assets look fine when viewing from a close distance of 1-2 meters, only when zoom out, the dark outlines appears and become more prenounced when the asset-pawn distance increase.

Hi Makigirl!

Thanks for the advice. I did have on-screen msg turned on but choose to ignore them since too many issues at hand. Set poolsize to 5000MB now and its somewhat better I think.

Regarding the face snap issue, I deleted most overlaying faces from relevant assets ( so the mouldings have no backside for example and just a thin front face ) and reimport and build them. It look definitely better than before but the issue still exist

I think the main problems are, these outlines appear darker & thicker as the viewing distance ( object to pawn ) increase. And these assets, including mouldings on furniture in particular, look generally fine from a 1-2 meter distances. Screenshot enclosed below:

The screenie door would look fine ( mostly ) when the pawn stay close. when its zoomed out, about 3 meters and beyond, these lines start to appear and they mostly concentrate in and around the mouldings. Another aspect of this is, if you quickly zoom out from a close view when the object in perfect status, the dark lines wont appear until pawn is 5-6 meters away. So quickly zooming out from close to afar seems to alleviate the problem more or less.

And if quickly pan the camera from a close-up view to another section of the map, these lines became really heavy ( entrance door angle view . quick pan-zoom ) as compared with a normal, more slowly pan would render ( entrance door angle view . normal ), as if the engine doesnt have enough time to render out the scene when the camera is panned quickly.

So maybe this issue is distance related? or have something to do with how the engine re-draw or render the same object for different vewing distance? is there settings that could at least reduce the issue somewhat if not complete eliminate them, since most of the object LOOK FINE when looking at close distance.

I’m guessing this is bleed caused by lower mipmaps, you’ll probably need to repack your lightmap UVs to support lower resolutions.

I’m not that familiar with mipmaps. Does lower resolution mean when you zoom out from a close-up view, a low res render setting kicks in? can you elaborate more on how this might contribute to the shadow line effect, thanks

I put two unwrap modifiers ( uv1 & 3, one on top of the other ) for most of the meshes routinely after I deleted all the overlaying polygons & backside as well. Then import them using datasmith. And some of the assets are forced with 2048 or 4096 res, but it doesnt seem to make much differences

Yes, the lower resolution mips (a mip is a lower-res version of the object/material) are transitioned to at farther view distances. The transition can be harsh or smoother, depending on settings for LODs and a few other things. LOD 0 is the highest mip, which is the maximum resolution of the image, and after that it’s usually 1, 2, 3…etc successively lower resolutions. However, it depends on the settings. LOD 1 can be set to be 50% resolution or higher/lower in LOD settings for the mesh, but there’s also the material that is connected to the mesh’s LODs by material editor settings. For the shadow lines effect, it could be lowering resolution in a way that’s causing shadow bleeding through, or if distance fields are in use then distance field resolution AND mesh/material resolution is decreased resulting in the shading difference. One thing to check is the textures for the meshes, and not only the diffuse (base color) texture, but also the normal map, AO map if there is one, and others. LOD settings are in the texture editor when opening a texture that are for adjusting how the texture is rendered per view distance, but also contain compression settings, which might be contributing to the unwanted effect too.

Hi @Allie.569 ,

Probably you already have hihg resolution lightmaps, right? But I think it’s a “fake” ambient occlussion effect. Go to you post process volume and put an AO intensity of 0, and 0 radius. And keep the checkboxes checked.