Dark lightning/enviroment while playing

I have a pretty simple torch blueprint - just mesh, sound, particle (from one of demos) and point light. Why my light are soo much darker when I am playing than in viewport? Im am trying to build a production quality lightning but it didn’t change antyhing.



And also the ambient dust particle are not visable while playing.

EDIT: The other lights, reflections etc. are also so much darker than in viewport so it’s not problem with my torch blueprint.

How is the environment built?
Have lightmaps been created for the surrounding walls, floor etc?

My first thought that the environment doesn’t have correct UV’s to bake the lighting.

Also the lights in the environment should be set to static or stationary if they aren’t already.

I am using a meshes from Unreal demos, so UV’s should be right.

I think I found a sollution. The problem is eye adaption. So i set a post processing volume and auto exposure → min brightness to 2 (max brightness to 1 but I unchecked this because my character blue body is too shiny). Also in World Settings I set diffuse boost do 2.5.

Viewport: http://puu.sh/b7RKw/688aaee941.jpg
Play in viewport: http://puu.sh/b7RMb/0cd69a5dcd.jpg
Play as standalone game: http://puu.sh/b7RNT/2fcf615d88.jpg

So its probably this. Is there a possibility to dissable eye adaption without the post processing volume? Or I just should make one big volume with this auto exposure settings?

Hey Etholt -

You are correct it is eye adaption (Auto Exposure) that is causing the lighting difference you are seeing. I would suggest making sure your post process volume is set to unbound (Checkbox toward the bottom of the volume’s details) and under Auto Exposure set the min and max brightness to exactly the same number, I usually use 1 and 1, but for your scene whether you want it brighter or darker you can change that value. As long as the numbers are the same you will get no eye adaption.

Thank You

Eric Ketchum