Download

Dark corners and pixelated shadows

Hi, 2 questions about the same scene:

QUESTION 1

Anyone knows how I can brighten the corners? Right now they are a bit dark for my taste.
Ambient occlusion is turned off.
Lights are static, light bake is set to production quality
In lightmass settings I tried increasing the diffuse boost, and while it lightened the corners it also made the whole image look yellow.
Untitled-1.jpg

QUESTION 2

Is there a way to smooth pixelated shadows? Lightmap resolution is set to 1024 in this example, and as you can see it’s still pixelated.
HighresScreenshot00000.png

Thank you

You can use the saturation parameter in the post processing volume to minimize the color bleeding, it looks as if your lights or sky are contributing to the yellow color.

Can’t help you with the rest, sorry.

  1. Try increasing “Indirect lighting intensity” from your sun. Also tweaking “Indirect lighting smoothness” under World settings could help out a bit. You could also use something like bounce cards for lights.
  1. Are all of your walls in that room one mesh or separated. Because it’s better to split into several pieces for lightmaps, then you can tweak them individual where you need more resolution. When they are all in one UV space for a whole room, even increasing to 2K often won’t be enough. You can also use Alt+0 command to view lightmap density and see where you need to increase it and where not.

Thank you. I’ve followed your advice and things are looking better. What do you think?
About the pixelated shadows, well you’r right, the walls are all 1 object so the lightmaps are distributed over a large area. I’ll try to break it up and make new uv maps.
V_001.png

Change your directional light from “static” to “stationary” in order to make your direct shadows smoother.

As for the corners, have you made sure that both the ambient occlusion post process effect and the lightmass setting are disabled?