Custom Vertex Painting Breaks Speedtree Wind


I am using a simple vertex color blend material to blend between two textures on the trunk of a speedtree I built.

The issue is that as soon as I begin painting custom vertex colors the speedtree wind stops working on the tree I am painting on. I have tried everything to get the wind to work again but to no avail. Additionally if I remove the custom painted vertex colors with the remove button the wind begins to work again.

Help! I cannot seem to get this working.

Attached is my simple material node graph.


Yeah I looked over that thread but the thread ends without anyone giving an answer as to what is breaking. So sadly it does not help me. :frowning:

There was a discussion about similar issue. Maybe it will help you.

Actually, Ryan’s comment in that post is valid and works.
Speedtree is very closed, but since I never used it due to it being very closed I dont know if they save the wind-information in vertex paint or a seperate uv-map.

you would need to export a fresh tree, open it in max/maya/whatever and see if the tree is vert-painted or has a special uv-channel that has the vertices in such an order that it works with the wind-module stuff.

if its a vertex color, just dont use that specific color, if its a uv-channel, make sure you dont touch that uv channel.

anyways, as i said, ryans approach should work.

Perhaps I am missing something but I don’t see how Ryan’s approach answers this. That solution is for a gradient shader that uses the scale of the object to determine the gradient. That does not give a result that I want in my tree.

Further it does not matter what channel I paint with the vertex tool using any channel at all makes the wind stop working.

Additionally I know that the AO exported from speed tree uses the red channel of the vertex colors for the AO darkening. Even painting that causes the wind to break so I don’t think there is a way to “avoid” the vertex color as you suggest.

Right. so apparently, I don’t see objective reasons for vertex colors not to work.

Are you painting mesh or its specific instance?

Does happen only if you drag and drop your tree into the world or only if you use it as foliage actor, painting landscape with it, or actually both?

Right now I am seeing this problem on the placed instance. I have not tried it on a foliage actor.

OK! So I got in touch with the Speedtree people and it looks like this is a bug in Unreal.

Apparently this issue got fixed in changelist 3094681 which didn’t make it into 4.1.3.

So hopefully in a future version of the Engine the problem goes away. I will report back once a new version drops and I can test it.