Custom Map Textures Missing on Dedicated Server - Fine in Singeplayer, Easy Fix??

I’ve created a Custom Map, been testing it here and there in SinglePlayer Mode. . . Finally decided to launch it up on a Public Dedicated Server and the ground textures on the entire landscape are still Alpha as well as what seems like half the dinosaur spawns aren’t working Specifically Online SinglePlayer is 100% fine.

Is this an easy fix? Maybe a check box that I can change? Something in the Landscape/World Settings?

Any help would be GREATLY appreciated.

WickWillow Island must continue!

Did you cook the map, and upload it to steam and then install it as a mod on your dedicated server?

Yes I have. I’ve cooked, uploaded, then copied the exact folder that is downloaded into the mods titled “496483916” over to the Mods folder on the Dedicated Server folder/Machine. Then my command line is:

C:\WickWillow\ShooterGame\Binaries\Win64\ShooterGameServer.exe "/Game/Mods/496483916/Cake?QueryPort etc. . . with “ModID=496483916” finishing the commandline string.

I appreciate the reply a great deal

Shouldn’t it be ‘-MapModId=496483916’

At least that’s how the Ark Server Manager would load it up for me on my custom map. With my own map ID ofcourse :smiley:

I didn’t know about that! I will give that a try and let you know if it helps! Thanks!

If that doesn’t work I’d strongly suggest you install the Ark Server Manager if you can. It makes install mods, etc, super easy.

Yeah Sadly changing the command line still resulted in missing Terrain Textures. So odd! Are you talking about the ARK Server Launcher that Drake released? Or is it something different from somewhere else? I have the one from Drake, I’ll go ahead and give that a shot. It was giving me Query Port Issues last time I tried using it so I went back to the basic command line

yeah that’s the one!

So yeah I basically cooked my map, uploaded to steam. Got the mod ID number and then went to “Mods” in the server manager and manually searched for my mod #. Doing the general search didn’t seem to work… Then I installed the map, made it priority 0, and then just made the server use the map.

I have a feeling though it won’t solve your issues though because they seem to run a bit deeper. Are you sure that any altered assests are moved to your mod folder the ADK? Sounds almost like all the files aren’t being included when the map is cooked.

If you put the map up and give me the address I’ll log in and tell if you if i get the same issue!

So now I’m able to at least use that ARK Server Manager Tool without Query issues but yet again the same issue with the Terrain Textures is still an all Alpha Grey world. . . I’m wondering if maybe there’s a specific Level LOD that I have to use or if there’s a certain check box for painted layers maybe something along those lines. I’m starting to think it must have something specifically to do with Networking/Dedicated Servers I just can’t figure out what exactly.

For what it’s worth these are my stock settings:

Hmmm. . . Well how I made my texture for my terrain was basically by duplicating Mat_TheIsland as well as TheIsland_Mat_Hole_Inst or w.e texture and placing it in the content folder within my mod folder that I made, then selecting those from within my own content folder as the source of the painted material, I also took each of the 22 materials and placed them into my content folder. . . Maybe this was more than needed? I just think it’s odd that it works in SinglePlayer or even Host Non Dedicated Session with Textures.

Hmmm, so you didn’t have to duplicate that texture? You just used it from the PrimalGameData Directly?

(Thanks again for helping)

Yeah that’s odd that it works on single player but not when installed as a mod.

You only need to move files into the folder that you modify, not the ones you’re just using. For example if you make a custom map and paint it with beach sand texture you only need to have the map files in your mod folder, not the beach sand texture.

If you said “you know, I like this beach sand but I want it to be a bit darker…” and you modified the beach sand texture you would then need to copy one to your mod folder, edit that one, and reference it.

Eg, Copy beach sand texture to mod folder -> name texture file TuskonysBeachSand -> edit new texture -> paint terrain with reference to TuskonysBeachSand

But I don’t know if having extra files in your mod folder will effect the outcome of the map cooking.

Hmmm, so a possible fix would be to try and select the texture I’m using but in the correct file path since it’s not a modified asset? Then try using the correct pathed textures which might involve completely retexturing the map but if that’s what it takes I’ll do it.

I missed this but yes, you only need to copy files you modify.

Thanks so much for the help, I’ll give the new texture a try and see if that does anything. . . Be back with results!

I would think you should just be able to point your landscape material to the default one /Game/PrimalEarth/Environment/Landscape/Mat_TheIslandWithMasks_Inst

I could hug you right now, you’re a genius! I’m able to repath the textures to the correct layers in the right path. I can’t thank you enough right now for helping me figure this out. Thank you Thank you Thank you! Now I just need to do this for 8 more terrains! :slight_smile:

No problem! I’m pretty new to ADK so I’m glad I was able to help you out :slight_smile:

There’s so much depth to this program it can be incredibly confusing at times, You’re the greatest!