Download

Custom Landscape with UE4 4.26 Water

I’m trying to use a landscape I created with World Machine and Zbrush with the new 4.26 Water plug- in.

The issue I’m having is the way the Water Plug in works the spline is controlling the shape of the shore and how the land is cut off.


I thought maybe disabling the Affects Landscape option would work but that just makes the water disappear altogether. It does almost look like it will work for a second before disappearing.

water 003

I saw this issue was addressed at 23:48 in the Water System Deep Dive | Inside Unreal video

However I’m trying to make sense of how to actually implement this. I tried connecting the UnpackRG8Height node directly to the PackRG8Height but it doesn’t seem to change anything

Perhaps given the video is from Jan 11, 2021 this problem has been solved already?

I’m curious has anyone tried this out and gotten it to work successfully?

Also how do I scale out the water to be bigger and go out to the horizon? Whenever I try to physically change the size of water it just makes the spline circle bigger. I know there’s an option that makes it render out to the horizon ( I forgot what it was called) but that didn’t work for me either.

It’s far more complex than I care to explain yet again in another pointless forum post.

The gist:
Dump the epic made trash. Create your own system.

Look up Edios videos about the ocean for Sapienza in Hitman.
It explains how they managed to implement the tide like / water current system as well.

You can find some decent working examples in the community ocean project. However dated it may be.

And remember that past 200 or so meters from the camera you’ll never be able to tell a regular wave from a normal map unless you are doing some sort of massive tidal waves above 10m tall.

What matters most is probably automated flow mapping and customizable flow from flow map render targets.
So look that up as well.

Between research and implementation from 0 knowledge expect the process to take a minimum of 2 months.

  1. Select your WaterBodyOcean.
  2. Set the falloff mode to Width.
  3. Set the width to 0.

(Now you can also turn off enable edit layers on your landscape if you like. In my experience they were a terrible mess.)

It took me a long time to figure out, but with those steps taken, using the Epic water system with a custom heightmap landscape is actually quite productive and enjoyable.
Although it may, or may not work for you, since this obviously disables some of the features of the Epic water system.

@MostHost_LA yeah that’s not something I want to dive into at the moment. But it would be good to figure out one day.

@XilenceX I tried this. It does seem to work …kinda. I need to test it a bit to see if it will work for my situation without any issues.