Download

Current bugs with mods cooked with 190 devkit (in 192 client/server)

Hi devs,

Thought I’d highlight the current issues, so you can tick them off in the next devkit/patch release.

  1. 190 cooked mods **do **work in single/non-dedicated mode… but have incomplete functionality in dedicated server mode (see below for further details)
    —UPDATE: if your PrimalGameData file doesn’t start with PrimalGameData… rename it so it does. This is confirmed fix for me.
  2. 190 cooked mods, even with nothing in WorldSettings for Force Load Map… still show up in Maps rather than Mods… in the Single Player/Non-Dedicated Mods page
    —UPDATE: see 1) above… also fixed by renaming.
  3. Syntax for launching dedicated servers to use TheIsland (or any true map mod), when using a mod that has nothing in Force Load Map… is not documented.
    ----UPDATE: to load a mod only (without a map) use the following:

Dedicated server start line:
ShooterGameServer.exe TheIsland?listen?(etc.etc.) if you want to use vanilla TheIsland
ShooterGameServer.exe /Game/Mods/[map mod id]/[map mod level name]?listen?(etc.etc.) if you want to use a mod that has a map

Dedicated server GameUserSettings:
[ServerSettings]
ActiveMods=[non-map mod id]{,[non-map mod ud]}

  1. Unreal Editor does not delete unused files in the \Projects\ShooterGame\Content\Mods folder, or in the ModTools/Output folders
    —UPDATE: known issue. Manually delete files for now.
  2. Steam updates for clients do not delete files no longer present in the mod (believe its a Steam issue but wanted to track it).
    —UPDATE: known issue: Manually delete files for now/.
    For 1) above features in 190 mods that do work in 192 dedi servers:
  • dino_characters that are cheat summoned

For 1) above features in 190 mods that do NOT work in 192 dedi servers:

  • any changes to status value definitions in PrimalGameData (e.g. renaming Health to MyHealth)
  • engrams (do not appear at all in dedi… but do appear after the L70 engrams in single/non-dedi regardless of required level)
  • cannot cheat summon items by full path

Hope this helps.

My post from anothe tread

Some Stackable Mod funktions dont work together

On dedicated server, all my mod’s engrams appear just fine (remap inline, additional at the very botoom), and I can also cheat summon items by full path (exactly as documented in the v190 change thread from Drake). If you can’t do either of these, there must be a reason, such as if you are using the new arrays in v190 or not.

Mine as well… and I have custom objects, structures, etc… I have not, however, modified any original assets. Everything I have created so far is considered a “new” item.

I can confirm what JasonFJ is experiencing… EXACT same thing with my mod and my server.

Except I can cheat in items… but they crash the server.

Why oh why, can’t we just get an ‘Additional Item list’ like the MasterItemList.
It would solve ALL these problems.
My mod works PERFECTLY if I add onto the MasterItemList.

My additional Engrams only show up in the editor play mode.
The XP level changes are working though.

I can confirm that the engram remap array does not function on a dedicated server, but does function on a single player session. The same can be said for the structure placer array and when you replace items on the master engram list. Also, if you create your own playerpawntest (duplicate, not subclass) and reparent playerpawntest_male and playerpawntest_female to it and then apply it to the mod, your character will no longer be able to whistle.
My reference is two days of trying to figure out how to make my mod work on a dedi server while it worked wonderfully on single player. I’m glad this is an identified issue and I’m not alone :slight_smile: I hope you guys fix it soon! =)

Not having any problems here with any of the below listed arrays in GameData_BP for my mods built in v190 running on a dedicated server v192. This includes cheating in placeable structures that are cheat only, remapped engrams, new placeable structures, and reworked iron ingot recipes.
df0481e13f84c8e1c0ac6c68a07eeef0e8203a38.png

Drathek… do you remember if you created your mod from the GenericMod folder files; map, primalgamedata, testgame? Or did you copy them from the PrimalEarth/CoreBlueprints folders? I’m pretty sure I used the ones in GenericMod but maybe that’s a difference?

My mod has a new engram and structure (standing torch variant), renamed Health/Stamina labels… and a bunch of dino character BP + dinostatuscompoennt variants. The dinos I am not remapping, but rather adding only via spawners. Interestingly… the engram, torch and renamed labels don’t appear… but the dino variants do spawn on the map and can be cheat summoned. This is all dedi mode… single and non-dedi work fine.

P.S. I deleted and completely re-installed a dedicated server on 2 different PCs… and the same result on both. So it’s not a dedicated server install issue.

Hey all, I think the issue is that Mods are now actually required to have their PrimalGameData asset actually have “PrimalGameData” somewhere withinin the asset name (such as “BP_MyModPrimalGameData”). We forget to mention this, it’s a little hack for now to allow us to find the right gamedata asset for the mod to use. We’ll do away with this requirement later, but if you have that missing, it will cause the Mod to be listed as a Map within the game UI, and also then it indeed won’t load properly when used as a Mod on a dedicated server. I believe that’s what’s causing the #1 and #2 issues described above currently, and this will be cleaned up via a dedicated Cook button for Mods vs Maps going forward so we don’t have to rely on our name checking hack. Never the less, one of our engineers will be following-up to make sure that is fully working for you all :slight_smile:

(as for #4 and #5, the extra files may indeed be a little annoying, but that doesn’t actually cause any problems at the moment, right? :wink: )

Thanks,
Drake

All of my assets were created as children of the original wherever possible (particle systems and structures I replaced the particle template were duplicated). Nothing was from the generic mod. Maybe the name of the gamedatabp, that Drake mentioned, is all that is wrong?

Not for me, my mod is named PrimalGameData_COGAU.

Tho my PrimalGameData does not look like yours… Mine is a direct child of the main PrimalGameData_BP

So in current release looks like your primal game data has to start with “PrimalGameData” vs just contain it in asset name. This will be changing in the next release. Also your primal game data has to be in the root mod folder for now.

I’d love to talk to someone that is having this issue with their mod and to know if recooking with these two changes (name/location) fixes it for them.

Example server command line: “ShooterGameServer.exe TheIsland?GameModIds=111111111?SessionName=TestSession?listen”

This is mine;

https://drive.google.com/file/d/0B8w837zasrLdX0kzUkFTOEhweDA/view?usp=sharing

Works in sandbox, but not live servers.

do you have a “level” map in your mod directing the game to use your primalgamedata file?

yes, sorry didnt grab that in my sreenshot

How does your mod work on singleplayer? Also, when using the sandbox test, make sure that you have it set to simulate a dedicated server. From there we might be able to help you more.

Ok, I just cleaned up the mod directory, recooked and reuploaded. I unsubscribed, redownloaded and noticed that Steam is keeping old files?
Does the upload process not wipe the mod dir on Steam? Could be conflicts there…

Structures work after redownload now on SP but none of my items work even tho I can spawn them.
Checking the ‘Extra Resources’ now to make sure I have EVERYTHING in there.

EDIT:
Yep… all there.

No unfortunately steam workshop will not ever delete a file from your modid at this time. Also I will note that my primalgamedata is named PrimalGameData_BP_Boost

Oh my f_ god! Rename worked!

Renaming from A_UR190_PrimalGameData to PrimalGameData_UR190 has completely fixed the problem for me.
Now the mod actually shows up as a mod (instead of a map) in single/non-dedi… and correct loads in a dedi server.