Cubemap Rendering Edge Artifacts (Postprocess inconsistencies?)

Hi again!

It has come to my attention that in some scenarios the Cubemap capture component produces artifacts.

It looks a bit like the different sides of the cube have different eye adaption values or something like that.
But even when deactivating most post processes I was unable to find the culprit.

I saw this happening rather inconsistently among different projects.

To reproduce:

  1. Download the Infiltrator Demo and open it in 4.16

  2. Create a cube render target with maximum resolution

  3. Create a cube capture blueprint that follows the player camera and captures when you hit space (Or however you like)

  4. Capture a few Cubemaps while the robot outside attacks the Infiltrator (best with flashing lights)

  5. Inspect the Cubemaps

  6. Find seams in some Cubemaps

Cheers
Jannes

Hey Jannes-

If possible, could you elaborate on your steps? For example, can you provide a screenshot of your blueprint setup? Additionally, what do you mean by “maximum resolution” in your first step? Please provide as much detail as possible to help me reproduce the behavior you’re seeing on my end.

Hey Jannes-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers

Doug Wilson

Hi Doug!

I can do that.
So I attached some screenshots on how to reproduce this reliably.

  • Create and open the Infiltrator Project with the latest engine version (4.16.1)
  • Create a cube render target (default settings are fine)
  • Create a cube capture actor in the scene (default settings are fine)
  • Set the Matinee Actor to force start at 180 seconds (See attached images)
  • Set the transform of the cube capture actor to one of the ones in the screenshots
  • Open your render target in a separate tab so you can see it
  • Click Play in Editor
  • Pause after a few seconds
  • Frame step until the Matinee Sequence time matches the time of the screenshot you choose.
  • You should be able to see similar artifacts as in the screenshots
  • If not move the capture actor around a bit (It seems to happen a lot when particles overlap the cube sides)

I hope this helps!

Provided further information and more detailed steps to reproduce.

Hey JannesNagel-

Thank you for the additional repro steps. I was able to reproduce the behavior on my end and have entered a ticket here: Unreal Engine Issues and Bug Tracker (UE-46450) . You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.