CSV Import Too Few Rows

When I try to import a DataTable I get an error message saying that there are too few rows.

This is the code for the structure:

/** Structure that defines a level up table entry */
struct FCharacterData : public FTableRowBase


		: XPtoLvl(0)
		, XP(0)

	/** The 'Name' column is the same as the XP Level */

	/** XP to get to the given level from the previous level */
	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = LevelUp)
		int32 XPtoLvl;

	/** This was the old property name (represented total XP) */
	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = LevelUp)
		int32 XP;

And this is the CSV file:


I get the same error with curve table as well.

Any help would be appreciated. Thanks!

Okay, so it looks like the issue is that the engine code is looking specifically for \r\n patterns but the CSV file I had only had \n at the end of lines.

I added the carriage return characters, and now the import is successful. However, when I look at the imported file all I see is a blank screen.

I solved it :slight_smile:

The problem was that I was using Google Docs instead of excel, and Google Docs exports .csv files with trailing \n at the end of each line instead of trailing \r\n. So the solution is to have \r\n, or (this is what I did) to modify the engine to ignore \r.

How is done?