=== Critical error: === Failed to compile default material /Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial!

Hi, I have been having this error. This occurs when i try to package my project to linux and with source build.
I could build with empty project and engine 4.20

UATHelper: Packaging (Linux):   LogMaterial: Display: Missing cached shader map for material WorldGridMaterial, compiling. Is special engine material.
UATHelper: Packaging (Linux):   LogShaderCompilers: Warning: 0 Shader compiler errors compiling WorldGridMaterial for platform GLSL_150:
PackagingResults: Warning: 0 Shader compiler errors compiling WorldGridMaterial for platform GLSL_150:

UATHelper: Packaging (Linux):   LogWindows: Error: begin: stack for UAT
UATHelper: Packaging (Linux):   LogWindows: Error: === Critical error: ===
UATHelper: Packaging (Linux):   LogWindows: Error:
UATHelper: Packaging (Linux):   LogWindows: Error: Fatal error: [File:C:\Program Files\Epic Games\UnrealEngine-4.20\Engine\Source\Runtime\Engine\Private\ShaderCompiler\ShaderCompiler.cpp] [Line: 2031]
UATHelper: Packaging (Linux):   LogWindows: Error: Failed to compile default material /Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial!

PackagingResults: Error: === Critical error: ===
UATHelper: Packaging (Linux):   LogWindows: Error: [Callstack] 0x00007ff850ba73d7 UE4Editor-Engine.dll!FShaderCompilingManager::FinishCompilation() [c:\program files\epic games\unrealengine-4.20\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:2496]
UATHelper: Packaging (Linux):   LogWindows: Error: [Callstack] 0x00007ff85079da82 UE4Editor-Engine.dll!FMaterialShaderMap::Compile() [c:\program files\epic games\unrealengine-4.20\engine\source\runtime\engine\private\materials\materialshader.cpp:1594]

I used to have this error on an old project and another version. Try to look for assets in your game using this default material which is Editor only. Try also to exclude every folder which is not supposed to be packaged from packaging in your Packaging settings.

A good way to see if one of your assets you are packaging is referencing this Material, is to right-click on this WorldGridMaterial in the content browser and “Find References”. It should show you every asset referencing this WorldGridMaterial. Do not forget to enable “Show Engine content” and stuff like that in the content browser (can’t remember where this Material is).

Thank you for answering!
I copy-pasted my project to another location and cleared out content folder and then packaged. It gave same error, so it does not depend on what material I use in my project.
Also tried to make empty project and added a map, where is only one cube with WorldGridMaterial. This project was built with UE4.20 (Not source build) and build was successful.
There is some problem with my engine built from source.

Please go to your project properties, Platforms → Linux and disable GL3 there. For whatever reason there’s an issue compiling default material in your engine installation for GL3. This RHI has been long deprecated anyway, so by not supporting it you will only save yourself more trouble.

(The compilation of the default material shouldn’t fail nevertheless).

Thanks RCL! A quick question though: in 4.17 there is the same bug, even with just DX11 activated, do you know if there is a way to fix the problem in the 4.17 version?

Thank you! It worked, and DefaultMat didn’t fail. It compiled really slow tho…

[File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Engine/Private/ShaderCompiler/ShaderCompiler.cpp] [Line: 2397] Failed to compile default material /Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial!
, would just deleting gridmaterial fix it or …

Project wont’ start anymore and I’d really liked to get back in, sounds like an easy problem , just afraid to breaking something for good if I do the wrong thing…

Trouble also is , there is NO D:/build at all, whats up here ? ;00 :slight_smile: Is this temporary and it deletes all after crash ?

Thx anyone


1 Like

For me.Enable “Support global clip plane for Planer Reflections” called this issue.Disable it in config file will fix it.

And in case of this problem in Windows. How do I resolve this? I just had this problem and I can’t EVEN get into Unreal 4.27.2. How do I solve this problem? PLEASE HELP!!!