Download

Creating a hole replaces Landscape Material

Hey Guys,

i try to create a hole in my landscape. I habe both materials assigned. The hole material is set to masked and the landcape visibility node is plugged into the opacity.

When i apply the material with the visibility tool the hole shows up but removes the landscape material and replaces it with the hole material in a certain area. I really dont know whats going on there, Any advice for me?

Not applied: http://imgur.com/W4sEvu5

Applied: http://imgur.com/TBUREcH

Thx

The entire Masked landscape material system is AFAIK a temporary hack until one day a better system comes along.

It is hard to see in your pictures. Either it is still compiling shaders after you painted in the hole (does waiting a minute or so fix it?), or you possibly exceeded the maximum number of textures allowed per component. How many textures are in the material?

Hey,
Shaders are not compiling. Waiting a few minutes has no effect. The Materials are pretty basic like you see in the screenshots. Only 4 Layers + 4 Normals. Not that big of deal i guess.

Imgur
Imgur

This is what the logfile says after hitting ctrl-klick to create a hole

“LogTexture:Display: Building textures: Texture2D_50 (BGRA8)”

But thats it.

No it is not that much. But just to be totally sure can you try replacing the diffuse + normal map texture one of your layers with the diffuse + normal of another one?
Just connect the texture sample from layer 3 also to layer 4 inputs, just to be totally sure it is not too many textures. Because if a material has too many textures it will show up exactly like it does for you.

Otherwise it may be a bug. I know the feature is buggy. I had it several times that it just doesn’t do anything at all, and then after a couple of restarts it suddenly begins painting holes again.

As far is I know hole material should be a full copy of your landscape material with

Ok i tried to create a new landscape material with only 1 layer and 1 normal. It changes nothing. :frowning:

Makes sense. And it works! So the tutorial to that was a little bit misleading for a beginner. Sculpt Mode | Unreal Engine Documentation

Yeah, documentation does not mention that, we will get it fixed!

Ah right you only connected the mask :slight_smile:

I thought that picture was just a test. Yeah the whole thing must be copied over.

Thx Guys! I really have to say that the mentality from you all is really nice, when it comes to helping other people! <3

duplicating the shader, setting it to masked and setting all the instance parameters to the same values like the landscape material is still the way to go in 2020? the documentation about the copying process is also not updated as promised in 2014…does noone use that feature?

The landacape uses a special node to create the hole.

Not sure if it was the same back then, however there are a lot of different YouTube tutorials you can follow on it in 2020 using almost all versions of the engine above .16