Download

Crazy Streaky Shadows (not light map related!) UE4.26.2

Hi all, I was hoping that there would be some feedback on a huge issue I’ve never had before on my baked lighting in UE4. Please see below details of the problem and would welcome any feedback / suggestions!

I have a third person map, in UE4.26.2; a small diorama that is producing insane streaky shadows (almost like a paint roller has run over the scene) regardless of what size the lightmap is, or even if I import custom lightmaps on the assets (props and floor) pieces.

Technicals are as follows:

1 x Skylight set to Movable
1 x Directional light (currently set to stationary, although the problem still persists when baked this light static)
8 x lightmass portals on the various openings of the building (as this is a derelict warehouse)
1 x unmodified default post process.

in the screen shots below the lightmap is at 256. increasing the lightmaps on these to 512 and above not only just impacts the bake time is makes this streakiness WORSE and does not solve the light problem. :confused:


lighting only overlay


512 lightmap bake


256 lightmap bake


lightmass settings


lightmap on floor pieces.

Any pointers at this stage would be super helpful! Thanks!!!

**bumping because i really need help! ***

Hello.
Have you tried removing the portals and switching the skylight to stationary or static?

Hello!

Yes I removed the portals and had both lights on stationary, below lighting result:


:frowning:

At least it looks quite artsy. :nerd_face:

From where are the assets? Made yourself? Maybe they are the problem. But I’v never seen something like that before. If you add some default Cubes (or other primitives from UE) outside of your building and hit the Bake button? Still the same? That would answer the question for the Modelling / Assets.

Do you have a Lightmass Importance Volume placed around your scene?

Hi!

Thank you, yes the assets are all made by me; I am in my dissertation module of my Master’s degree in Environment Art for video game, and this problem has completely thrown me as I’ve never had this kind of lighting issue before.

I just tried what you suggested and put a UE default cube in the scene and baked with lightmap resolution on the cube of 512, and the result is below, its the same, I don’t think it’s my meshes…

Yes i have a light mass importance volume. When the issue started I even deleted it and put in a brand new one just in case there was something wrong there but the issue persists :frowning:

Oh, ok … strange! But could you try placing the cube outside your building / level? And make a second cube, casting shadow on the first cube. So you can check, if anything within is causing the problem. Next step would be of course: Creating a new, blank level and try to bake the light again (with simple primitives at first, for example)

All shadows come from a light source that is located above and slightly to the left. I would like to see the building’s ceiling screen as well as a screen outside the building overlooking the roof. And of course the settings for both light sources.

Two stupid things to check quickly: Make sure that the lightmaps are using the correct uvs on your objects (ie, that they aren’t using coordinate 2 or 3 or something) and make sure that your uvs are what you think they are. IE, the shapes in the picture you posted look correct–not great, you could definitely improve your uvs a lot, you’re wasting a ton of space, but more or less correct-- but the faces could actually be the wrong faces, like the side being the top and the top being the side.

Your light map does look like it’s stretched, but I’ve never seen that weird, streaking effect before.
Can you post the screenshots with the lightmap visualizer please?

Edit: As a weird aside, this is a cool effect if you could do it intentionally, so it’d be interesting to figure out what’s going on.

Hello, thanks for your response, please see below screenshots of the roof panels (simple 3 x 3 corrugated iron style panels)

outside

view up to the ceiling

skylight

directional light

i also have the detault skysphere from the 3rd person map on this level

many thanks for your response!

This is probably unrelated but you’ve set your skylight to use a specified cubemap, then you didn’t specify a cubemap for it. Basically your skylight is doing nothing…

Hello!

Thanks for commenting :slight_smile:

Yes I checked the lightmap channels are on the correct co - ord , I also too had a moment a week ago where I thought I had accidently made the wrong face larger on the light map ! But I double checked it and it is the correct face.

Here’s the lightmap visualiser: lightmap density - i have some whack red results on the ivy and foliage at the moment, even though the foliage lightmaps do not overlap, this is another issue that this project is throwing up that I’ve not come across before, however the shadows that are causing the issue are being cast on the wall and floor pieces.

ah yes , forgot to change that back in as I had a cube map originally, just changed it back and baked. same crazy streaky error!

thanks for point it out though :slight_smile:

Well, there goes my suggestions. Ok, here’s another dumb suggestion, maybe your scale is off? What’s your scale like in real world units? Also, try messing with world scale and seeing what that does.

so, real world scale is 3 x 3m pieces. - largest texture at 2k, i’m working to a 6.87 texel density.

I’ll have a look at playing with the world scale too and see if that’s an issue.

looks to me to be almost related to the sample count of the rays cast by lightmass. what lightmap rendering quality are you using? try increasing the number of rays cast, you may have to touch some engine .ini files to get the right setting- i believe somewhere on the forums here is a thread about making Lightmass Epic and Usable! or something like that, and it has some great info about lightmass quality

256, tried at 512 and also a 1k bake , the more I increased the lightmaps resolution the more prominent and defined the streaky lines became, so the resolution of the lightmaps were increasing correctly, its just the baked shadows aren’t correct at all, i see what you mean about it being rays cast. i looked into it and tried a few things with the lightmass settings, but sadly no luck.

I suppose i could try and rebuild the whole scene again from scratch (however i did port over the level, assets only to a brand new project, and used default directional light, skylight, and a new lightmass importance volume) and the result was the same. which worreid me thinking it was my wall meshes themselves. so I used UE default primitives to build a quick test room. same results. it’s mad.