Crazy compile shaders

Every time when I change little thing in Landscape material give me tons of compile shaders, I die before find good looking landscape, you guys also this problem? Any trick you use or just make whole landscape to external programs? I try make photorealistic landscape and good optimization but this is almost imposible

what are the computer’s specs (CPU, RAM, GPU)?

i7 OC, rx570 8GB OC, 16GB RAM

Sounds more than simply capable. I was just watching a video in the Online Learning area of the site on why the engine compiles thousands of shaders. One thing it has to do with is the Usage settings in the material editor. Here’s a link to the video, with the discussion of it in the last half (so start at about 5 or 6 minute point):

If using static lighting, then certain materials may require the Used with Static Lighting flag enabled. But what I notice is there’s no ‘landscape’ flags in the list. Your problem sounds like an issue with landscape materials, and possibly how project settings might be interfering with it in such a way that a ton of shaders keep getting compiled every change. I had the same problem on a low-spec laptop I was using, where simply painting a little bit of the landscape would then compile up to 10,000 shaders +/- a few thousand! Try submitting a bug report about it, and post the same question in the AnswerHub. These areas of the forum don’t get frequented as often, I think, regarding that kind of issue.

ok thanks but i thing back to unigine, every step i have problem even if fix something another thing broken this is ridiculous

Landscape size is a huge factor. Each component has its own set of shaders.

to build new materials i usually make a level with the smallest possible single component landscape. It helps.

But how you connects this little landscape together and every little landscape got own material?

You don’t. you develop the material one layer at a time. when you are done compiling you use the material on the larger landscape and you paint it.