Crash with vulkan VK_ERROR_OUT_OF_DATE_KHR


I have a constant vulkan crash after some seconds: VK_ERROR_OUT_OF_DATE_KHR

Even with an new project.

My specs:

  • Unreal Engine 4.18.0-release (compiled, but no change to the sources)
  • Nvidia GTX 1080 (drivers 388.13)
  • Windows 10 1709
  • Visual studio 15.4.2

[crash folder][1]
[1]: (937 KB)

Edit: seems to be related to the drivers, after downgrading to 384.94 the editor does’n crash anymore at this point.

Hello gundz,

So I see that you updated this post saying that you are no longer having issues after downgrading your Graphics Card Drivers. Could you provide a little more information on what would happen when you were using the latest version? I just updated to 388.13 and have not been able to reproduce the crash you were seeing. When you opened a new project, would it crash without you doing anything, or were you performing any specific actions when the crashes occurred? Have you tried to do a clean install of the newest drivers?



hard so say, with anything specific i mean not oppening (window or asset) or creating something, just some mouse moving, maybe scrolling in the scene, activating the fps indicator.
It was really random, sometimes after a few seconds sometimes more.

But this specific error seems to be related to an recent nvidia driver update changelog, page 8

Hi again,

I tested to update my drivers on my home computer:
Drivers 388.13, GTX 970, Windows 10 7009

And the same crash occurs, totally randomly.

I have also general performances drop with direct x and opengl, and on vulkan my framerate seems to be locked on 60 fps (fresh project with the table chair) normaly at 120 fps

by the way, it is better to put these issues topics on this forum or on the udn ?

Hello gundz,

If you have access to UDN, that would be the best place to put any questions or bugs.


The way to reproduce this error is easy. launch a project with vulkan and then just try to simply click the Restore Down/Maximize button of the engine. it crashes every time

Fatal error: [File: D:\EpicGames\UE_4.18_git\Engine\Source\Runtime\VulkanRHI\Private\VulkanUtil.cpp]
[Line: 358] VulkanRHI::vkQueuePresentKHR(PresentQueue->GetHandle(), &Info) failed, VkResult=-1000001004
at D:\EpicGames\UE_4.18_git\Engine\Source\Runtime\VulkanRHI\Private\VulkanSwapChain.cpp:380

This is the full text of the error

So I’m completing my previous answer:
Alongside the windows that pops on crash on Windows I ran a few other tests:

All versions crash on Linux from 4.16 → 4.19 (but it crashes also in normal mode aka OpenGL4)
Version 4.18 and 4.19 crashes with the same message and I suspect all previous version implementing Vulkan

As pointed by gundz the change in NVidia’s drivers are clearly the cause. The editor crashes if you try to resize the editor frame or I guess when you tab out even tho I haven’t test it.

I’m pretty sure @RCaloca is aware of the problem tho ^^

Hi gundz, Nvidia sent us a patch for this, will make it into 4.19 and we’ll try to push it onto the next 4.18 patch release.

I just fixed this for 4.18.2 and will also be on 4.19.

sorry to bug you again about it, but when are you planning on releasing 4.18.2 (and thank you very much for fixing it by the way)

i think a release is planned very soon (next week or two more at the most), hopefully…


I just tested this commit

With the nvidia 387.34 drivers, and same issue for the moment.

Edit: Same issue on linux ! I haven’t tested on windows

Hi gundz, why did you downgrade your driver to 387.34? In your original post, you said you are using 388.13. The commit mentioned by Rolando does fix the issue, you should test it with a newer driver version.

Are you sure you are using the 4.18 branch and not the master one? I’ve been playing around after the commit and on linux I only had an issue with some tooltips, but on windows it went quite good.

I forgot to mention that i tested on linux and the 388.13 is not available on linux.

I’m also on linux, an daside a tooltip issue not displaying properly sometimes and a bit of lag, there is no crash (compiled and tested with very last update in 4.18.2)