Crash with blueprinted lightmass portal

If I add lightmass portal to blueprinted class with dragging and then press build engine crash.

If I select lightmass portal actor and some static mesh actor and press [Convert selected components to blueprint actor]
then engine crash immediatly. MachineId:1407D9314EDC59B183638FB365378655EpicAccountId:c157e8adeaa0419687bc98 -

I would want to add portals to window prefabs and for some emissive mesh prefabses. And I want to avoid manual placement.

Hi Jenny,

Thanks for taking the time to post this here in AnswerHub!

At the moment I cannot reproduce this on my end and I do have a couple of questions with your workflow that I may not be doing right to cause the crash.

So, here’s what I’ve tried.

  • I dragged a Lightmass Portal into the scene and then in the details panel used the Blueprint/Add Script option to convert this into a BP. I rebuilt lighting and didn’t have an issue.
  • Next, since lightmass portals go hand in hand with lightmass importance volumes I added one of these around the default level area and built lighting, still no crash.
  • I then created a new blank actor BP in the content browser and dragged a Lightmass Portal into the BP from the Modes panel with no other objects in the BP and built lighting, still no crash.
  • I then created another new blank actor BP with a Static Mesh that I added and then I dragged a Lightmass Portal into that from the Modes panel. I then built lighting, but no crash.

I may just be ignorant with how i would to do this, but how are you converting multiple objects into a BP from the scene. I don’t have that option that I see. If I place two objects (a static mesh and a lightmass portal) in my scene and I select them both I lose option to convert these to a BP in the details panel. Although the only option I see is under the Actor tab where I can select convert to BP, but that will convert them both individually. Still no crash on that part either.

If you wouldn’t mind sharing some information with how you set the convert to BP instant crash up.
Is the crash happening only in your project and in a new default level, or is this happening in a new blank project as well?

Can you also post your DxDiag here? Maybe there is something hardware related I can test in our compat lab that isn’t reproducible on my machine.

Thank you!


Tested more with empty project. Crash seems to be linked to Movable property. When I drag portal to StatMeshActor that mobility is static for some reason portal defaults to Movable. When I build with this setting then it crash. But If I set it to static then it does work. MachineId:1407D9314EDC59B183638FB365378655EpicAccountId:c157e8adeaa0419687bc98 -

I managed to crash once when I converted selected components(portal actor) to blueprint. MachineId:1407D9314EDC59B183638FB365378655EpicAccountId:c157e8adeaa0419687bc98 -

I’m still not seeing the same results on my end. I’ve made a simple video showing these two methods and the results. Maybe there is something that I’m still missing from your description that I just don’t do.

Test Video

Just to clarify my test project:

  • This is a new Blank project with Starter Content only.
  • Project was created with default settings in 4.11 p4 with Maximum Quality and Desktop/Console
  • Test uses new Default Level.

Thank for your time.
Yup, yup, yup.

Basically it’s not show stopper bug but crash bug nevertheless.

I’m seeing this too. The steps are a lot simpler than the video though.

  1. New Project.
  2. New Default level
  3. Drag Light Importance Portal to the level.
  4. Select the portal in the outliner.
  5. Select Blueprints->convert selected components to Blueprint, select “Create Blueprint” from new dialog - crash

This in the latest source build of UE4.12

Unfortunately, I’m not seeing the same thing on my end with the binary or source builds. Have you tried testing this in the Binary version from the launcher, and if so, do you still get the crash?

Can you post your Crash Logs and Call Stack (with Epic/Machine ID included) in a text file attached here.

Thank you!

Me and my colleague have the same crash occurring when trying to “Convert Selected Components to Blueprint Class”.
I kinda wonder why this thread is marked as solved because it isn’t and we have reproduced it on a number of systems.
The way I worked around is by creating a blueprint from the lightmass alone, thereafter add the other parts I need in this blueprint.


This was marked as resolved because the issue could not be reproduced and the user never responded back with the last information I had requested and I cannot reproduce the problem locally using their steps. The fact that the ticket was marked “resolved” does not indicate that there was in fact a resolution, only that the investigation here was either reported, solved by another means, or that it was not reprocible with the information that is currently provided.

If you have any additional steps that you use to make this happen that would be helpful to know since I don’t get the crash on my machine in 4.13.

Also, please post what version you are using, if it’s anything older than 4.13 please try the latest version and see if the issue still occurs for you. Include your Call Stack, Crash Log from the project, and your DXDiag.

Thank you!

That cleared it up thanks for explaining.
I created a version 4.13 project to reproduce the crash. My logs / Dxdiag are also included:

Open the level included and select the LightMassPortal + the Spotlight.
Now go to Blueprints in the top menu and click “Convert Selected Components to Blueprint Class”. For me this will crash the engine. If you need more info please let me know !

hmm…I’ve got the crash now. I never used the Blueprint toolbar button to convert. No one even called me out on the attached Test Video above. Which converted fine. Heck, even just using the Lightmass portal by itself will convert fine using the Blueprint toolbar button, however, if you have any actor and a lightmass portal the crash will happen when converting.

Thanks for taking the time to help out!

You can follow the status here: Unreal Engine Issues and Bug Tracker (UE-35515)