Crash on opening editor with SteamVR running

After having not worked on my project in VR mode for a few weeks, I’ve returned to testing the game using my HTC . However, I am now unable to open the project, as the editor crashes at around 70%. This only occurs when I’m launching the project with SteamVR running, which is necessary to get the editor to recognise the headset and allow me to test in VR from the editor.

The crash reporter gives the following message:

Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:D:\Build\++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Core\Public\Modules\ModuleManager.h] [Line: 247] 
Tried to get module interface for unloaded module: 'LevelEditor'

UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
UE4Editor_UnrealEd!FModuleManager::GetModuleChecked<FLevelEditorModule>() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\modules\modulemanager.h:247]
UE4Editor_UnrealEd!UEditorEngine::GetActiveViewport() [d:\build\++ue4+release-4.14+compile\sync\engine\source\editor\unrealed\private\playlevel.cpp:3412]
UE4Editor_SteamVR!FindSceneViewport() [d:\build\++ue4+release-4.14+compile\sync\engine\plugins\runtime\steam\steamvr\source\steamvr\private\steamvrhmd.cpp:46]
UE4Editor_SteamVR!FSteamVRHMD::EnableStereo() [d:\build\++ue4+release-4.14+compile\sync\engine\plugins\runtime\steam\steamvr\source\steamvr\private\steamvrhmd.cpp:1011]
UE4Editor_Engine!UEngine::InitializeHMDDevice() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\engine\private\unrealengine.cpp:2145]
UE4Editor_Engine!UEngine::Init() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\engine\private\unrealengine.cpp:807]
UE4Editor_UnrealEd!UEditorEngine::InitEditor() [d:\build\++ue4+release-4.14+compile\sync\engine\source\editor\unrealed\private\editorengine.cpp:499]
UE4Editor_UnrealEd!UEditorEngine::Init() [d:\build\++ue4+release-4.14+compile\sync\engine\source\editor\unrealed\private\editorengine.cpp:668]
UE4Editor_UnrealEd!UUnrealEdEngine::Init() [d:\build\++ue4+release-4.14+compile\sync\engine\source\editor\unrealed\private\unrealedengine.cpp:53]
UE4Editor!FEngineLoop::Init() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:2354]
UE4Editor_UnrealEd!EditorInit() [d:\build\++ue4+release-4.14+compile\sync\engine\source\editor\unrealed\private\unrealed.cpp:66]
UE4Editor!GuardedMain() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launch.cpp:136]
UE4Editor!GuardedMainWrapper() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]

My SteamVR version is listed as 2017-01-31 (1485823399) in the SteamVR diagnostics. The last time I used the in the editor was around mid-January.

This is definitely a new issue, maybe related to a SteamVR update? I would like to avoid updating to 4.15 if possible, since the project is already quite far in development and switching would likely be time consuming.

It is important for me to find some sort of solution quickly, as I am under pressure to complete this project in a short time span. Being able to test in-editor with my is a necessity to get things done quickly.


Hello Valax321,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?


I tried reproducing the crash on a clean VR template, and was unable to. I tried adding code to the project and changed the settings and plugins to be similar to that of my main project, to no avail.

As for settings/blueprints that could cause the crash, I can’t really find anything that seems to be related to this issue. I had added some C++ code to the project since last launching with my headset, but nothing added was related to VR.

@Valax: This is a random guess of something to try, but can you move the SteamVR and/or HeadMountedDisplay module (in your Project.cs…) to the end of the Module list?

Thanks for the suggestion, but there’s nothing relating to SteamVR in either the Target.cs or Build.cs file. As far as I am aware, most of the VR modules are loaded from engine plugins.

If you are still unable to open the project. You could try going through your project folder and removing a few assets at a time to see if can get he project to open (removing a few at a time to help narrow down what asset (if any) may be causing the crash). Please note that you will want to make a back up of the project and any files removed so that they assets not involved in the issue can be added back in. After running through this process, could you then come back and post any additional information you may have?

It’s not really feasible for me to spend the time removing the large number of assets I have in the project. From what I can tell from the stack trace, the crash does not even occur during asset loading. It seems to be occurring during the editor initialisation.

Does the error message indicate a specific source of the problem?

I have recently also tried migrating my project to 4.15, but the issue still persisted. I was able to launch without SteamVR, but crashed otherwise. The crash reporter did not offer up any message after about 15 minutes of waiting, so I closed it.

Would it be possible for you to provide a simplified version of your project that reproduces the issue that you are experiencing so that I could take a closer look?

I can confirm Valax321 struggles with the editor crashing after opening when SteamVR opens and runs as well. I have had this happen in multiple projects using the VR template. I do not know what the issue it tho.

What happens is you double click the uproject file to open. Both the project starts to open in the editor and SteamVR starts to run. Once everything is loaded, you can begin working in the editor for a minute or so and then, for whatever reason, the editor freezes and you are unable to move your mouse. You then have to end the application through the task manager or wait for the editor to crash.

I thought it may be linked to the project settings of VR editing and auto entry when the headset is moved. I also thought it may be tied to the loss of tracking to the controllers or headset while not using them and editing the project. Still have not been able to find the problem, but it is quite annoying and very delaying to work in the project…

Hope someone figures this out.

this seems to be mentioning the same thing, but I am still experiencing this is binary of later installs

Hello Bamwd5,

I have a few questions for you (the same that I asked of Valax321) that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?
  4. Could you provide your complete callstack (including machine/loginID)?
  1. I cannot intentionally reproduce yet, however, many of my VR templated projects have this issue (maybe 50%)
  2. I cannot yet.
  3. I can try to post the settings images from certain projects in a bit. I doubt its blueprints unless its from the VR template blueprints.

Please be sure to update the thread when you have more information and I will be happy to investigate further.



These are the only settings that I can think of that would even relate. I have had this problem in multiple projects, so if it is a blueprint, it is the VR template blueprints.

I cannot think of anything else that would be causing this. In my opinion, it has to be either a bug in the startup of SteamVR and UE4 and their communication together. OR there is something wrong with my setup (but I have tried reinstalling and everything is up-to-date)

Hope to hear something soon, its impossible to work in a project and test easily.

When you crash you will get a crash reporter window. Could you provide your complete callstack (including machine/loginID)?

This happens because “Start In VR” is TRUE.

Turn that off, you should be able to get into the editor again.

Hello Valax321,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Hello Vawx

After doing some digging I was able to find that this is a known issue. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-42791)

Make it a great day