[Crash] Engine crashes when i open up bp's with Error: ECEPTION_ACCESS_VIOLATION reading address 0x000


While working with some blueprints my engine crashed out of nowhere. Moreover, it doesn’t opens back up. It gives the same error over and over again. I changed the editor startup level to a blank one and finally managed to open the project. However, whenever i try to open a blueprint the projects crashes again with the same error.

The error leads to this line in one of the engine folders called MembersReference.h

And now my whole project is gone and I’m both furious to my self and the engine. I would really appreciate the help you will be saving me lots of hair! Thanks in advance!!

For those in the future that might be having the same problem. This might not be your solution but it helped me so better to try it.

  1. Find the corrupted file by deleting the blueprints one by one (First delete by groups try if it works, then go smaller)
  2. After you found the responsible file go to the project/saved/autosaves/folder
  3. If you are lucky enough you will have a backup for that file if so replace it with backup
  4. Delete the file and the child bp’s (if there are any)
  5. This should solve the problem if we have the same one