Crash / BP corrupt after changing material

  • I changed a material on a UStaticMeshComponent in blueprint.
  • Tried to save; it said: Due to reference to external HOTRELOADED something… not able to save.
  • I closed Editor.
  • Afterwards, if trying to ope BP, unreal crashes.
  • If started with VS the following assert is provided:
    Assertion failed: InSCSNode->ComponentTemplate != NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Editor\Kismet\Private\SSCSEditor.cpp] [Line: 3101]

I am experiencing 5 to 10 crashes (if not more) per day with unreal editor…

I manged to find a backup created earlier this day. Replacing with that one, i can open the BP again.

Hi simmania,

I ran some quick tests in 4.6.1 and was not able to see the behavior that you described. If you could provide some additional information, that would be very helpful.

  • What version of the Engine are you using, and is it the binary version installed by the Launcher, or did you build the Engine from source code?
  • Have you seen this error again since you reported this issue?
  • Do you recall what changes you were making and hot reloading just before this issue occurred?
  • Did the crash occur only when opening the one Blueprint that was affected? All other Blueprints were fine?

Tim

  • 4.6.1
  • Yes, It happens regularly when changing the material type on the StaticMeshComponent. But it may have to do with the complexity of the material.
  • Only the one opened.

I think it is very much related to the fact that HotReload is not working properly and is changing the type of custom internal classes.

See also (i think its all the same bug)

Hey simmania -

I am helping Tim try to track this issue down for you can you let me know what the Material Domains, Blend Modes, Shading Models, (if Translucent) Translucency Lighting Modes and whether you are using any World Position Offset or Tessellation in your two materials?

Thank You

Eric Ketchum

MaterialDomain:PostProcess
BlendModes: Cannot choose in PostProcess domain
ShadingModels: Cannot choose in PostProcess domain
Translucent: Same, cannot choose in PostProcess domain
No Position Offset nor Tesselation.

I think it is very much related to this bug as well:

You need a custom component (C++ class) and use it in your blueprint. By making changes to the custom component and doing HotReload, you will possibly experience this bug or one of the other bugs i’ve posted on this.
Hot Reload makes changed C++ classes unknown - Programming & Scripting - Unreal Engine Forums Cast fails if HotReload has changed component type - Programming & Scripting - Unreal Engine Forums How to reload config if editor is already open - Programming & Scripting - Unreal Engine Forums

Sorry for the delay on this issue. We are a little confused by something. Are you applying a post process material directly to a static mesh?

Tim

Hi simmania -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Eric Ketchum