Couldn't run "./Hero-Linux-Debug": Permission denied

Hi guys, i’m working with CodeLite 9.0 in Ubuntu 14.04.3 and i cand build the debug project but i have a very bad problem, i can’t run it because i haven’t permissions.

I can’t build correct the project in CodeLite: [link text][1]

But when i try to execute de generated file this say me that i haven’t permissions, i try use gksudo nautilus to change the permissions but it doesn’t lefy me change the permission, so anyway to execute it.

I have UnrealEngine folder in personal folder and Unreal Projects in other partition disk, aren’t in the Linux default partition, maybe can be a problem.

Can anyone help me?

Seems like you might of botched your permissions…Did you try to run a graphical application using Sudo thru a terminal? Try changing the permissions of the files under the binaries folder with chown back to your user thru a terminal. If still doesn’t let you post the permissions as shown using

ls -lXa 

in the binaries folder

Ok, i try all, but with any solution.

You can see this here:

Have you tried running the executable directly from the terminal?
Just to rule out group permission issues having to do with Codelite

Yes, i tried with ./Hero… and with sudo ./Hero…

  1. Did you ./ ./ and make run as sudo? Just to make sure that you didn’t.
  2. How did you start your executeable? In the terminal? Or withing CodeLite?
  3. Do you use a NTFS partition?

It looks like the binary for some reason doesn’t have +x permission. Is your /media drive mounted noexec by any chance? If it’s not, try chmod +x Hero-Linux-Debug and then ./Hero-Linux-Debug.

That said, it will probably crash right if run that way. Normally, standalone games are first packaged (to some directory) and then run from there - in your case it looks like you are trying to run the standalone game binary without packaging the game first (i.e. producing the pak file etc).

Yes, it’s a /media drive but isn’t auto mounted, i mount manually ever time that i init sesion, i try using chmod but doesn’t works. I’m not know why happen this.